summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHa The Tung2018-07-26 11:44:24 +0800
committerHa The Tung2018-07-26 11:44:24 +0800
commitcfb0f8275a6fd95512b4ad21f1d54a5d35e8d267 (patch)
tree19b94c8262a09bad1af0b92900d167a8214e393a
parent24d868ed096ac9e94d5ae94628c2b3443a0b93a7 (diff)
downloadaur-cfb0f8275a6fd95512b4ad21f1d54a5d35e8d267.tar.gz
2.6.0-1
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD17
2 files changed, 16 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c9b7373a3b12..b313f51016f0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,17 @@
-pkgbase = php70-xdebug
+pkgbase = php71-xdebug
pkgdesc = PHP extension module that aids debugging and profiling
- pkgver = 2.5.5
+ pkgver = 2.6.0
pkgrel = 1
url = http://www.xdebug.org
arch = i686
arch = x86_64
license = GPL
- depends = php70
- source = https://www.xdebug.org/files/xdebug-2.5.5.tgz
+ depends = php>=7.1
+ source = https://www.xdebug.org/files/xdebug-2.6.0.tgz
source = xdebug.ini
- sha256sums = 72108bf2bc514ee7198e10466a0fedcac3df9bbc5bd26ce2ec2dafab990bf1a4
+ sha256sums = b5264cc03bf68fcbb04b97229f96dca505d7b87ec2fb3bd4249896783d29cbdc
sha256sums = 7c66883dc2ade69069ef84e30188b25630748aa9c8b0dd123727c00505421205
-pkgname = php70-xdebug
- backup = etc/php70/conf.d/xdebug.ini
+pkgname = php71-xdebug
+ backup = etc/php71/conf.d/xdebug.ini
diff --git a/PKGBUILD b/PKGBUILD
index 42ceabcda79a..b5f59cecfd17 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,17 @@
#
-# Maintainer: Michael Rynn <michael.rynn@parracan.org>
+# Maintainer: Tung Ha <tunght13488 [at] gmail [dot] com>
+# Contributor: Michael Rynn <michael.rynn@parracan.org>
# Contributor: Sergej Pupykin <pupykin.s+arch@gmail.com>
# Contributor: Jonathan Wiersma <arch aur at jonw dot org>
# Contributor: Thore Bödecker <me [at] foxxx0 [dot] de>
#
# Credit to all other past PHP version AUR packages
-php_suffix="70" # This mutation
+php_suffix="71" # This mutation
+php_version="7.1"
php_ext="xdebug"
pkgname="php${php_suffix}-${php_ext}"
-pkgver="2.5.5"
+pkgver="2.6.0"
pkgrel=1
@@ -17,15 +19,14 @@ pkgdesc="PHP extension module that aids debugging and profiling"
arch=('i686' 'x86_64')
url="http://www.xdebug.org"
license=('GPL')
-depends=("php${php_suffix}")
+depends=("php>=${php_version}")
pkg_src="${php_ext}-${pkgver}"
source=("https://www.xdebug.org/files/${pkg_src}.tgz" 'xdebug.ini')
-sha256sums=(
- '72108bf2bc514ee7198e10466a0fedcac3df9bbc5bd26ce2ec2dafab990bf1a4'
- '7c66883dc2ade69069ef84e30188b25630748aa9c8b0dd123727c00505421205')
+sha256sums=('b5264cc03bf68fcbb04b97229f96dca505d7b87ec2fb3bd4249896783d29cbdc'
+ '7c66883dc2ade69069ef84e30188b25630748aa9c8b0dd123727c00505421205')
# locate php-config[suffix], get options
@@ -144,7 +145,7 @@ package() {
make INSTALL_ROOT="$pkgdir" install
install -D -m 644 "$srcdir"/xdebug.ini "$pkgdir/${PHPCONFIG_SCANDIR}/xdebug.ini"
- install -D -m755 "./debugclient/debugclient" "${pkgdir}/usr/bin/debugclient70"
+ install -D -m755 "./debugclient/debugclient" "${pkgdir}/usr/bin/debugclient${php_suffix}"
}
# Run this before the backup file variables get evaluated
if [[ -z $PHPIZE_CMD ]]; then