summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHa The Tung2017-05-31 10:00:48 +0700
committerHa The Tung2017-05-31 10:00:48 +0700
commitf81f0e3b4ba5ac178674f82f192c2e7c0d5ca163 (patch)
tree6e039bf445818327e43a749c026b0869ba13ef55
parent8aecbdc7f856f46bb43176012b34e2e061baa5aa (diff)
downloadaur-f81f0e3b4ba5ac178674f82f192c2e7c0d5ca163.tar.gz
fix conflict on /usr/bin/debugclient
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD22
2 files changed, 15 insertions, 10 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..8abd449fb4e6
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+*.tgz
+*.tar.xz
+
diff --git a/PKGBUILD b/PKGBUILD
index e5e28fcad2bb..b67361004efa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: Sergej Pupykin <pupykin.s+arch@gmail.com>
# Contributor: Jonathan Wiersma <arch aur at jonw dot org>
# Contributor: Thore Bödecker <me [at] foxxx0 [dot] de>
-#
+#
# Credit to all other past PHP version AUR packages
php_suffix="70" # This mutation
@@ -34,13 +34,13 @@ sha256sums=(
php_select()
{
declare -a php_configy # paths
-
+
# pass a folder to be searched for any php-config*
findconfig()
{
local _myglob="$1/php-config${php_suffix}*"
- for f in $_myglob;
+ for f in $_myglob;
do
if [ "$f" != "$_myglob" ]; then
php_configy+=("$f")
@@ -70,11 +70,11 @@ php_select()
exit -1
elif [[ $optct -eq "1" ]]; then
php_config="${php_configy[0]}"
- else
+ else
declare -a php_options # assemble user menu
optct=0
php_options+=("0) Get me out of here!")
- for cfg in "${php_configy[@]}";
+ for cfg in "${php_configy[@]}";
do
let optct='((optct+1))'
PHP_FULL_VERSION=`${cfg} --version`
@@ -100,7 +100,7 @@ php_select()
let choice='((choice-1))'
php_config="${php_configy[$choice]}"
fi
-
+
#get some config options, assumable from php70
all_options=`${php_config} --configure-options`
@@ -121,7 +121,7 @@ php_select()
prepare()
{
echo "PHPIZE path is ${PHPIZE_CMD}"
- echo "PHP scan directory is $PHPCONFIG_SCANDIR"
+ echo "PHP scan directory is $PHPCONFIG_SCANDIR"
}
build() {
cd "$srcdir"/$pkg_src
@@ -137,14 +137,16 @@ build() {
package() {
backup=("${PHPCONFIG_SCANDIR}/xdebug.ini")
- cd "$srcdir"/$pkg_src/debugclient
- make DESTDIR="$pkgdir" install
+ #cd "$srcdir"/$pkg_src/debugclient
+ #make DESTDIR="$pkgdir" install
cd "$srcdir"/$pkg_src
make INSTALL_ROOT="$pkgdir" install
install -D -m 644 "$srcdir"/xdebug.ini "$pkgdir/${PHPCONFIG_SCANDIR}/xdebug.ini"
+
+ install -D -m755 "./debugclient/debugclient" "${pkgdir}/usr/bin/debugclient70"
}
# Run this before the backup file variables get evaluated
if [[ -z $PHPIZE_CMD ]]; then
php_select
-fi \ No newline at end of file
+fi