summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEugene Lamskoy2022-11-05 19:45:51 +0200
committerEugene Lamskoy2022-11-05 19:45:51 +0200
commit5c10ea9f5e253963326e57a80e87d86267a9afe5 (patch)
tree62e9329188e967a4cb50072e6b74c7e9faaa62b0
parent0120e679d5cf4e64894f7620d040daf2067195a3 (diff)
downloadaur-5c10ea9f5e253963326e57a80e87d86267a9afe5.tar.gz
Fixed build with openssl 3
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD7
-rw-r--r--openssl-sslv3-consts.patch12
3 files changed, 22 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6009a3d87d52..a7bcf25b96e8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
-# Generated by makepkg 6.0.1
-# Fri Feb 18 10:52:48 UTC 2022
+# Generated by makepkg 6.0.2
+# Sat Nov 5 17:44:22 UTC 2022
pkgbase = php72
pkgdesc = PHP 7.2.34 compiled as to not conflict with mainline php
pkgver = 7.2.34
- pkgrel = 11
+ pkgrel = 12
url = http://www.php.net
arch = x86_64
license = PHP
@@ -71,6 +71,7 @@ pkgbase = php72
source = php-apache.conf
source = https://php.net/distributions/php-7.2.34.tar.xz
source = php71-phar-names.patch
+ source = openssl-sslv3-consts.patch
source = fpm-numeric-uid-gid.patch
source = fpm-reload-sighup.patch
source = mysql-socket-php7.1.patch
@@ -89,6 +90,7 @@ pkgbase = php72
sha256sums = 6d0ad9becb5470ce8e5929d7d45660b0f32579038978496317544c5310281a91
sha256sums = 409e11bc6a2c18707dfc44bc61c820ddfd81e17481470f3405ee7822d8379903
sha256sums = ee6529d441b2446d784e80aba23aa956541e541bd73ad54aee480d4a1a6117ca
+ sha256sums = aecd8dff7022e956718407a5b98dec19acdceef08b0a58e7266b483bc3845de6
sha256sums = d175f0c14fdb22855090c93f76e18f04320d7bf15afc057ffde947f9bb361242
sha256sums = f5ae925036744a5e88cea2698879aea0498e1e23aee7801923d90f16be383908
sha256sums = 0a3a6e8ff04ff1e0869befcf2c7bca4e886d94065da6d7a10b809a4750b961a0
diff --git a/PKGBUILD b/PKGBUILD
index f9da613745c6..b899d6ff5f4d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -16,7 +16,7 @@
_phpbase="72"
_suffix=""
pkgver="7.2.34"
-pkgrel="11"
+pkgrel="12"
pkgbase="php72"
pkgdesc="PHP 7.2.34 compiled as to not conflict with mainline php"
_cppflags=" -DU_USING_ICU_NAMESPACE=1 -DU_DEFINE_FALSE_AND_TRUE=1 "
@@ -133,6 +133,7 @@ source=(
"php-apache.conf"
"https://php.net/distributions/php-${pkgver}.tar.xz"
"php71-phar-names.patch"
+ "openssl-sslv3-consts.patch"
"fpm-numeric-uid-gid.patch"
"fpm-reload-sighup.patch"
"mysql-socket-php7.1.patch"
@@ -211,6 +212,7 @@ arch=(
)
_patches=(
"php71-phar-names.patch"
+ "openssl-sslv3-consts.patch"
"fpm-numeric-uid-gid.patch"
"fpm-reload-sighup.patch"
"mysql-socket-php7.1.patch"
@@ -304,7 +306,7 @@ _phpconfig="\
--libdir=/usr/lib/php${_phpbase}${_suffix} \
--datadir=/usr/share/php${_phpbase}${_suffix} \
--program-suffix=${_phpbase}${_suffix} \
- --with-config-file-scan-dir=/${_build_conf_d}
+ --with-config-file-scan-dir=/${_build_conf_d} \
--enable-filter \
--with-pear \
--enable-session \
@@ -1546,6 +1548,7 @@ sha256sums=('e6b8530d747000eebb0089249ec70a3b14add7b501337046700544883f62b17b'
'6d0ad9becb5470ce8e5929d7d45660b0f32579038978496317544c5310281a91'
'409e11bc6a2c18707dfc44bc61c820ddfd81e17481470f3405ee7822d8379903'
'ee6529d441b2446d784e80aba23aa956541e541bd73ad54aee480d4a1a6117ca'
+ 'aecd8dff7022e956718407a5b98dec19acdceef08b0a58e7266b483bc3845de6'
'd175f0c14fdb22855090c93f76e18f04320d7bf15afc057ffde947f9bb361242'
'f5ae925036744a5e88cea2698879aea0498e1e23aee7801923d90f16be383908'
'0a3a6e8ff04ff1e0869befcf2c7bca4e886d94065da6d7a10b809a4750b961a0'
diff --git a/openssl-sslv3-consts.patch b/openssl-sslv3-consts.patch
new file mode 100644
index 000000000000..f8075216683b
--- /dev/null
+++ b/openssl-sslv3-consts.patch
@@ -0,0 +1,12 @@
+--- a/ext/openssl/openssl.c
++++ b/ext/openssl/openssl.c
+@@ -1482,7 +1482,9 @@
+ REGISTER_LONG_CONSTANT("PKCS7_NOSIGS", PKCS7_NOSIGS, CONST_CS|CONST_PERSISTENT);
+
+ REGISTER_LONG_CONSTANT("OPENSSL_PKCS1_PADDING", RSA_PKCS1_PADDING, CONST_CS|CONST_PERSISTENT);
++#ifdef RSA_SSLV23_PADDING
+ REGISTER_LONG_CONSTANT("OPENSSL_SSLV23_PADDING", RSA_SSLV23_PADDING, CONST_CS|CONST_PERSISTENT);
++#endif
+ REGISTER_LONG_CONSTANT("OPENSSL_NO_PADDING", RSA_NO_PADDING, CONST_CS|CONST_PERSISTENT);
+ REGISTER_LONG_CONSTANT("OPENSSL_PKCS1_OAEP_PADDING", RSA_PKCS1_OAEP_PADDING, CONST_CS|CONST_PERSISTENT);
+