summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEugene Lamskoy2021-11-30 20:49:03 +0200
committerEugene Lamskoy2021-11-30 20:49:03 +0200
commitac96fb3f4708eae2c1eb0db4bb280d156b84aa9e (patch)
treeafa68eed0600c1c3443b2a260ea217db1c6171a6
parent275e9a5dda94a59db901600c9564e7741a5a2c71 (diff)
downloadaur-ac96fb3f4708eae2c1eb0db4bb280d156b84aa9e.tar.gz
Fix for icu patches
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD2
-rw-r--r--icu.patch55
3 files changed, 41 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 22b769d8da12..3f9202f80708 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -40,7 +40,7 @@ pkgbase = php72
source = php-freetype-2.9.1.patch
md5sums = adb64072b9b7e4634844a72512239a34
md5sums = 3bcefa76cf2f73f5f851a95c92e217a1
- md5sums = 3cb2095ab40f225a4048704685ae783f
+ md5sums = 3e7039d5ef6074b5153d9d7087503c21
md5sums = 13cda50a6a420d04ddc26935ded3164e
md5sums = b7d69762f7c045b3950d770e04db504c
md5sums = f248c783449f310291905b5551c57e48
diff --git a/PKGBUILD b/PKGBUILD
index 4add6e1476d9..26947d87947e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -353,7 +353,7 @@ package_php72-sodium() {
}
md5sums=('adb64072b9b7e4634844a72512239a34'
'3bcefa76cf2f73f5f851a95c92e217a1'
- '3cb2095ab40f225a4048704685ae783f'
+ '3e7039d5ef6074b5153d9d7087503c21'
'13cda50a6a420d04ddc26935ded3164e'
'b7d69762f7c045b3950d770e04db504c'
'f248c783449f310291905b5551c57e48'
diff --git a/icu.patch b/icu.patch
index cc652ff1ef04..1c1ab8ddffab 100644
--- a/icu.patch
+++ b/icu.patch
@@ -1,27 +1,50 @@
---- a/ext/intl/breakiterator/codepointiterator_internal.cpp
-+++ b/ext/intl/breakiterator/codepointiterator_internal.cpp
-@@ -75,7 +75,11 @@ CodePointBreakIterator::~CodePointBreakI
- clearCurrentCharIter();
+--- 7.2.34/ext/intl/breakiterator/codepointiterator_internal.cpp 2020-09-30 08:15:54.000000000 +0300
++++ 7.2.34/ext/intl/breakiterator/codepointiterator_internal.cpp 2021-11-30 20:43:09.078705667 +0200
+@@ -74,7 +74,11 @@
+ clearCurrentCharIter();
}
-
+
+#if U_ICU_VERSION_MAJOR_NUM >= 70
+bool CodePointBreakIterator::operator==(const BreakIterator& that) const
+#else
UBool CodePointBreakIterator::operator==(const BreakIterator& that) const
+#endif
{
- if (typeid(*this) != typeid(that)) {
- return FALSE;
---- a/ext/intl/breakiterator/codepointiterator_internal.h
-+++ b/ext/intl/breakiterator/codepointiterator_internal.h
-@@ -39,7 +39,11 @@ namespace PHP {
-
- virtual ~CodePointBreakIterator();
-
+ if (typeid(*this) != typeid(that)) {
+ return FALSE;
+--- 7.2.34/ext/intl/breakiterator/codepointiterator_internal.h 2020-09-30 08:15:54.000000000 +0300
++++ 7.2.34/ext/intl/breakiterator/codepointiterator_internal.h 2021-11-30 20:45:34.371317671 +0200
+@@ -36,8 +36,11 @@
+
+ virtual ~CodePointBreakIterator();
+
+#if U_ICU_VERSION_MAJOR_NUM >= 70
-+ virtual bool operator==(const BreakIterator& that) const;
++ virtual bool operator==(const BreakIterator& that) const;
+#else
- virtual UBool operator==(const BreakIterator& that) const;
+ virtual UBool operator==(const BreakIterator& that) const;
+-
++#endif
+ virtual CodePointBreakIterator* clone(void) const;
+
+ virtual UClassID getDynamicClassID(void) const;
+--- 7.2.34/ext/intl/locale/locale_methods.c 2020-09-30 08:15:54.000000000 +0300
++++ 7.2.34/ext/intl/locale/locale_methods.c 2021-11-30 20:46:15.912078221 +0200
+@@ -1333,7 +1333,7 @@
+ if( token && (token==cur_lang_tag) ){
+ /* check if the char. after match is SEPARATOR */
+ chrcheck = token + (strlen(cur_loc_range));
+- if( isIDSeparator(*chrcheck) || isEndOfTag(*chrcheck) ){
++ if( isIDSeparator(*chrcheck) || isKeywordSeparator(*chrcheck) || isEndOfTag(*chrcheck) ){
+ if( cur_lang_tag){
+ efree( cur_lang_tag );
+ }
+@@ -1558,7 +1558,7 @@
+ # define BANG "!"
+ #else
+ # define BANG
+-#endif
+#endif
+ if(zend_parse_parameters( ZEND_NUM_ARGS(), "as|bS" BANG, &arr, &loc_range, &loc_range_len,
+ &boolCanonical, &fallback_loc_str) == FAILURE) {
+ intl_error_set( NULL, U_ILLEGAL_ARGUMENT_ERROR, "locale_lookup: unable to parse input params", 0 );
- virtual CodePointBreakIterator* clone(void) const;