summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEugene Lamskoy2021-12-01 20:54:17 +0200
committerEugene Lamskoy2021-12-01 20:54:17 +0200
commit70e7bd133d68acb505e4fc9a2ba1aa7272a9b96c (patch)
tree4f454dde685f810793bf990ebf297c4e4f09d90b
parent2318b6fe15dc78fabc3ef142aa58052d2d7e9dc4 (diff)
downloadaur-70e7bd133d68acb505e4fc9a2ba1aa7272a9b96c.tar.gz
Igbinary unified pkgbuild
-rw-r--r--PKGBUILD25
1 files changed, 13 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 50e1228b5552..17b430f7287d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,36 +1,37 @@
_phpbase=72
-pkgname=php72-igbinary
+_suffix=
+pkgname="php${_phpbase}-igbinary"
_pkgname=igbinary
pkgver=3.2.6
pkgrel=1
-pkgdesc="php72 extension igbinary"
+pkgdesc="php${_phpbase} extension igbinary"
url="http://pecl.php.net/package/igbinary"
arch=('x86_64')
license=('PHP')
-makedepends=("php${_phpbase}")
-depends=("php${_phpbase}")
-backup=("etc/php${_phpbase}/conf.d/igbinary.ini")
-source=("http://pecl.php.net/get/igbinary-${pkgver}.tgz")
+makedepends=("php${_phpbase}${_suffix}")
+depends=("php${_phpbase}${_suffix}")
+backup=("etc/php${_phpbase}/conf.d/${_pkgname}.ini")
+source=("http://pecl.php.net/get/${_pkgname}-${pkgver}.tgz")
md5sums=('6970abb34217faff470767c2b84ea2da')
build() {
- cd "$srcdir/igbinary-$pkgver"
+ cd "$srcdir/$_pkgname-$pkgver"
phpize${_phpbase}
- ./configure --prefix=/usr CFLAGS="-O2 -g" --enable-igbinary
+ ./configure --prefix=/usr CFLAGS="-O2 -g" --enable-igbinary --with-php-config=php-config${_phpbase}
make
}
check() {
- cd "$srcdir/igbinary-$pkgver"
+ cd "$srcdir/$_pkgname-$pkgver"
NO_INTERACTION=1 make test
}
package() {
cd "$srcdir/igbinary-$pkgver"
- make INSTALL_ROOT="$pkgdir" install
+ make INSTALL_ROOT="$pkgdir" install
install -D -m0644 \
- "${srcdir}/${_pkgname}-${pkgver}/igbinary.php.ini" \
- "${pkgdir}/etc/php72/conf.d/igbinary.ini"
+ "${srcdir}/${_pkgname}-${pkgver}/${_pkgname}.php.ini" \
+ "${pkgdir}/etc/php${_phpbase}/conf.d/${_pkgname}.ini"
install -D -m0644 \
"${srcdir}/${_pkgname}-${pkgver}/COPYING" \
"${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"