summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEugene Lamskoy2019-01-31 23:42:38 +0200
committerEugene Lamskoy2019-01-31 23:42:38 +0200
commit23779ba8033d09b1f7dd3df3ab9ad38244dd1418 (patch)
tree791ccf2cb1e40b7584024c97240cf13971ab82d5
downloadaur-23779ba8033d09b1f7dd3df3ab9ad38244dd1418.tar.gz
Initial
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD30
3 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9c30f3c55968
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = php72-xdebug
+ pkgdesc = Xdebug is an extension for PHP to assist with debugging and development
+ pkgver = 2.6.1
+ pkgrel = 1
+ url = https://xdebug.org/
+ arch = x86_64
+ license = Xdebug
+ depends = php72
+ backup = etc/php72/conf.d/xdebug.ini
+ source = http://pecl.php.net/get/xdebug-2.6.1.tgz
+ md5sums = 35cc0f2e8b7d40556a9ad9afd9c49aee
+
+pkgname = php72-xdebug
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..5683296c03ee
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+php71*
+pkg/*
+src/*
+xdebug/*
+*.tar.*
+*.t?z \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8ce213658c20
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+pkgname=php72-xdebug
+_extname=xdebug
+pkgver=2.6.1
+pkgrel=1
+pkgdesc="Xdebug is an extension for PHP to assist with debugging and development"
+arch=("x86_64")
+url="https://xdebug.org/"
+license=('Xdebug')
+depends=('php72')
+makedepends=()
+source=("http://pecl.php.net/get/$_extname-$pkgver.tgz")
+backup=("etc/php72/conf.d/$_extname.ini")
+
+build() {
+ cd "$srcdir/$_extname-$pkgver"
+ phpize72
+ ./configure
+ make
+}
+
+package() {
+ cd "$srcdir/$_extname-$pkgver"
+ install -m0755 -d "$pkgdir/etc/php72/conf.d/"
+ install -m0644 -D "LICENSE" "${pkgdir}/usr/share/licenses/$pkgname/LICENSE"
+ echo ";zend_extension=$_extname.so" > "$pkgdir/etc/php72/conf.d/$_extname.ini"
+ chmod 0644 "$pkgdir/etc/php72/conf.d/$_extname.ini"
+ install -m0755 -D ".libs/$_extname.so" "$pkgdir$(php-config72 --extension-dir)/$_extname.so"
+}
+
+md5sums=('35cc0f2e8b7d40556a9ad9afd9c49aee')