summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTomasz Gruszka2022-05-17 10:28:02 +0200
committerTomasz Gruszka2022-05-17 10:28:02 +0200
commitfb564920509361794a8fc6bf6e80a6573390d645 (patch)
tree6a77d031a9905388e266c17be019c5130e99982c
parent86ae8bfded17a36462696cebbe3c1ea74978bb7f (diff)
downloadaur-fb564920509361794a8fc6bf6e80a6573390d645.tar.gz
Added missing json module required by tests.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD4
2 files changed, 3 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9cd81efd0f3b..b7bf936f320d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = php74-redis
pkgdesc = An API for communicating with the Redis key-value store
pkgver = 5.3.7
- pkgrel = 1
+ pkgrel = 2
url = https://pecl.php.net/package/redis
arch = x86_64
license = PHP
diff --git a/PKGBUILD b/PKGBUILD
index 539c5c453000..a0f08e2eb6e1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@ pkgname=php74-redis
_name=redis
_upstream=phpredis
pkgver=5.3.7
-pkgrel=1
+pkgrel=2
pkgdesc="An API for communicating with the Redis key-value store"
arch=('x86_64')
url="https://pecl.php.net/package/redis"
@@ -44,7 +44,7 @@ check() {
# tests are partly broken:
# https://github.com/phpredis/phpredis/issues/1593
export TEST_PHP_EXECUTABLE=/usr/bin/php74
- export TEST_PHP_ARGS="--no-php-ini -d extension=igbinary -d extension=${srcdir}/${pkgname}-${pkgver}/modules/redis.so"
+ export TEST_PHP_ARGS="--no-php-ini -d extension=json -d extension=igbinary -d extension=${srcdir}/${pkgname}-${pkgver}/modules/redis.so"
cd "$pkgname-$pkgver"
tests/mkring.sh start
$TEST_PHP_EXECUTABLE $TEST_PHP_ARGS tests/TestRedis.php --class Redis