summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEugene Lamskoy2023-02-22 17:42:51 +0200
committerEugene Lamskoy2023-02-22 17:42:51 +0200
commitfb156e29649efb4efec1c80476633fd2ce7a37d3 (patch)
tree6002ad7d8bb38fbba4659dc77845a454e5aa58b5
parent26b5408d82719f7878e5c022bb6de055a9a4215e (diff)
downloadaur-fb156e29649efb4efec1c80476633fd2ce7a37d3.tar.gz
3.1.5
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD47
-rw-r--r--xdebug.ini5
3 files changed, 34 insertions, 34 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 84b5fd59f3e7..13f36febf562 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,14 @@
pkgbase = php74-xdebug
- pkgdesc = PHP debugging extension
- pkgver = 3.1.6
+ pkgdesc = php74 Xdebug extension
+ pkgver = 3.1.5
pkgrel = 1
url = https://xdebug.org/
arch = x86_64
+ arch = i686
license = Xdebug
- depends = php74
- backup = etc/php74/conf.d/99-xdebug.ini
- backup = etc/php74/conf.d/xdebug.ini
- source = https://xdebug.org/files/xdebug-3.1.6.tgz
- source = xdebug.ini
- sha256sums = 554eca0b4d5b7b93cb2258fab0b0bd84cc8721e74322a2255c14e137cbcad5d2
- sha256sums = SKIP
+ makedepends = php74
+ source = http://pecl.php.net/get/xdebug-3.1.5.tgz
+ sha256sums = 55f6ef381245da079b2fc5ce1cfbcb7961197d0c0e04f9d977613cf9aa969a79
pkgname = php74-xdebug
+ backup =
diff --git a/PKGBUILD b/PKGBUILD
index aa4fcac5f832..36af733b3dd8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,36 @@
-# Maintainer: Tomasz Gruszka <tompear79@gmail.com>
-_php=php74
-_phpize=phpize74
-pkgname="${_php}-xdebug"
-pkgver=3.1.6
+ext_name=xdebug
+phpbase=74
+suffix=
+pkgname="php${phpbase}-${ext_name}${suffix}"
+pkgver=3.1.5
+source=("http://pecl.php.net/get/$ext_name-$pkgver.tgz")
pkgrel=1
-pkgdesc="PHP debugging extension"
-arch=("x86_64")
+pkgdesc="php${phpbase}${suffix} Xdebug extension"
+arch=("x86_64" "i686")
url="https://xdebug.org/"
license=('Xdebug')
-depends=("${_php}")
-source=("https://xdebug.org/files/xdebug-${pkgver}.tgz"
- "xdebug.ini")
-sha256sums=('554eca0b4d5b7b93cb2258fab0b0bd84cc8721e74322a2255c14e137cbcad5d2'
- 'SKIP')
-backup=("etc/${_php}/conf.d/99-xdebug.ini" "etc/${_php}/conf.d/xdebug.ini")
+makedepends=("php${phpbase}${suffix}")
+backup=()
build() {
- cd "${srcdir}/xdebug-${pkgver}"
- ${_phpize}
- ./configure --prefix=/usr --enable-xdebug
- make
+ cd "${ext_name}-${pkgver}"
+ phpize${phpbase}${suffix}
+ ./configure \
+ --with-php-config=php-config${phpbase}${suffix}
+ make
}
package() {
- cd "${srcdir}/xdebug-${pkgver}"
- make INSTALL_ROOT="$pkgdir" install
- install -D -m 644 "${srcdir}/xdebug.ini" "${pkgdir}/etc/${_php}/conf.d/99-xdebug.ini"
+ cd "$ext_name-$pkgver"
+ _priority=40
+ ext_dir="$(php-config${phpbase}${suffix} --extension-dir)"
+ _ini_dir="/etc/php${phpbase}${suffix}/conf.d"
+ _ini_file="${_ini_dir}/${_priority}-${ext_name}.ini"
+ backup+=("${_ini_file}")
+ install -m0755 -d "${pkgdir}/${_ini_dir}"
+ echo "zend_extension=${ext_name}.so" > "${pkgdir}/${_ini_file}"
+ chmod 0644 "${pkgdir}/${_ini_file}"
+ install -m0755 -D ".libs/${ext_name}.so" "${pkgdir}/${ext_dir}/${ext_name}.so"
}
+
+sha256sums=('55f6ef381245da079b2fc5ce1cfbcb7961197d0c0e04f9d977613cf9aa969a79')
diff --git a/xdebug.ini b/xdebug.ini
deleted file mode 100644
index 779718ea93a9..000000000000
--- a/xdebug.ini
+++ /dev/null
@@ -1,5 +0,0 @@
-;zend_extension=xdebug.so
-;xdebug.remote_enable=on
-;xdebug.remote_host=127.0.0.1
-;xdebug.remote_port=9000
-;xdebug.remote_handler=dbgp