summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEugene Lamskoy2022-11-05 19:58:46 +0200
committerEugene Lamskoy2022-11-05 19:58:46 +0200
commitd5b8a68a4fdc34b085005fb3061363018bb147de (patch)
treeda9d59d23a273203254c09f117be5e23b8e08da6
parentaa9cf44bce36e8cd684be28569f6e65495fc5ecb (diff)
downloadaur-d5b8a68a4fdc34b085005fb3061363018bb147de.tar.gz
Fixed build against openssl 3
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD7
-rw-r--r--openssl-sslv3-consts.patch12
3 files changed, 21 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a35d2c7f131d..fd0699e166fa 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,9 @@
+# Generated by makepkg 6.0.2
+# Sat Nov 5 17:57:32 UTC 2022
pkgbase = php80
pkgdesc = PHP 8.0.25 compiled as to not conflict with mainline php
pkgver = 8.0.25
- pkgrel = 1
+ pkgrel = 2
url = http://www.php.net
arch = x86_64
license = PHP
@@ -68,6 +70,7 @@ pkgbase = php80
source = php-makefile-patcher.php
source = php-apache.conf
source = https://php.net/distributions/php-8.0.25.tar.xz
+ source = openssl-sslv3-consts.patch
source = debian-php-8.0.patch
source = php-phpinfo.patch
source = timezonedb-guess.patch
@@ -77,6 +80,7 @@ pkgbase = php80
sha256sums = ba72fc64f77822755a469314160d5889d5298f4eb5758dd7939dac9b811afe52
sha256sums = 6d0ad9becb5470ce8e5929d7d45660b0f32579038978496317544c5310281a91
sha256sums = a291b71d0498707fc5514eb5b9513e88f0f1d4890bcdefd67282ded8a2bfb941
+ sha256sums = aecd8dff7022e956718407a5b98dec19acdceef08b0a58e7266b483bc3845de6
sha256sums = 9281736f0cbc60699992f92359a62d861c9c53391fd53e3826e77710ab981718
sha256sums = 558e780e93dfa861a366c49b4d156d8fc43f17898f001ae6033ec63c33d5d41c
sha256sums = 40bcc1e5058602302198d0925e431495391d8469499593af477f59d84d32f764
diff --git a/PKGBUILD b/PKGBUILD
index 2a2c777218bb..1844125d6984 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -16,7 +16,7 @@
_phpbase="80"
_suffix=""
pkgver="8.0.25"
-pkgrel="1"
+pkgrel="2"
pkgbase="php80"
pkgdesc="PHP 8.0.25 compiled as to not conflict with mainline php"
_cppflags=" -DU_USING_ICU_NAMESPACE=1 "
@@ -129,6 +129,7 @@ source=(
"php-makefile-patcher.php"
"php-apache.conf"
"https://php.net/distributions/php-${pkgver}.tar.xz"
+ "openssl-sslv3-consts.patch"
"debian-php-8.0.patch"
"php-phpinfo.patch"
"timezonedb-guess.patch"
@@ -136,8 +137,6 @@ source=(
)
depends=(
)
-checkdepends=(
-)
makedepends=(
"acl"
"libtool"
@@ -198,6 +197,7 @@ makedepends=(
arch=(
)
_patches=(
+ "openssl-sslv3-consts.patch"
"debian-php-8.0.patch"
"php-phpinfo.patch"
"timezonedb-guess.patch"
@@ -1522,6 +1522,7 @@ sha256sums=('e6b8530d747000eebb0089249ec70a3b14add7b501337046700544883f62b17b'
'ba72fc64f77822755a469314160d5889d5298f4eb5758dd7939dac9b811afe52'
'6d0ad9becb5470ce8e5929d7d45660b0f32579038978496317544c5310281a91'
'a291b71d0498707fc5514eb5b9513e88f0f1d4890bcdefd67282ded8a2bfb941'
+ 'aecd8dff7022e956718407a5b98dec19acdceef08b0a58e7266b483bc3845de6'
'9281736f0cbc60699992f92359a62d861c9c53391fd53e3826e77710ab981718'
'558e780e93dfa861a366c49b4d156d8fc43f17898f001ae6033ec63c33d5d41c'
'40bcc1e5058602302198d0925e431495391d8469499593af477f59d84d32f764'
diff --git a/openssl-sslv3-consts.patch b/openssl-sslv3-consts.patch
new file mode 100644
index 000000000000..f8075216683b
--- /dev/null
+++ b/openssl-sslv3-consts.patch
@@ -0,0 +1,12 @@
+--- a/ext/openssl/openssl.c
++++ b/ext/openssl/openssl.c
+@@ -1482,7 +1482,9 @@
+ REGISTER_LONG_CONSTANT("PKCS7_NOSIGS", PKCS7_NOSIGS, CONST_CS|CONST_PERSISTENT);
+
+ REGISTER_LONG_CONSTANT("OPENSSL_PKCS1_PADDING", RSA_PKCS1_PADDING, CONST_CS|CONST_PERSISTENT);
++#ifdef RSA_SSLV23_PADDING
+ REGISTER_LONG_CONSTANT("OPENSSL_SSLV23_PADDING", RSA_SSLV23_PADDING, CONST_CS|CONST_PERSISTENT);
++#endif
+ REGISTER_LONG_CONSTANT("OPENSSL_NO_PADDING", RSA_NO_PADDING, CONST_CS|CONST_PERSISTENT);
+ REGISTER_LONG_CONSTANT("OPENSSL_PKCS1_OAEP_PADDING", RSA_PKCS1_OAEP_PADDING, CONST_CS|CONST_PERSISTENT);
+