summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEugene Lamskoy2021-12-31 12:38:39 +0200
committerEugene Lamskoy2021-12-31 12:38:39 +0200
commitc32d5e8d00d1d4e7d244ca6d74aae601032de7a5 (patch)
treee3008cb5db603b05cdeb534e1ef55ef75703fdeb
parente8409ddbd0759d18b7d837d78f259cd0fd0f99dc (diff)
downloadaur-c32d5e8d00d1d4e7d244ca6d74aae601032de7a5.tar.gz
Tests fixed. Systemd added deps for building on chroot. Happy 2022
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD20
2 files changed, 16 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index aa42d45990d0..e98fb5018e59 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by makepkg 6.0.1
-# Sat Dec 18 09:18:53 UTC 2021
+# Fri Dec 31 10:29:16 UTC 2021
pkgbase = php81
pkgdesc = PHP 8.1.1 compiled as to not conflict with mainline php
pkgver = 8.1.1
- pkgrel = 1
+ pkgrel = 2
url = http://www.php.net
arch = i686
arch = x86_64
@@ -55,6 +55,8 @@ pkgbase = php81
makedepends = bzip2
makedepends = gdbm
makedepends = zlib
+ makedepends = systemd
+ makedepends = systemd-libs
source = pear-config-patcher.php
source = php-apache.conf
source = https://php.net/distributions/php-8.1.1.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
index 93e42a56e875..87d508d2ccef 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_phpbase="81"
_suffix=""
pkgver="8.1.1"
-pkgrel="1"
+pkgrel="2"
pkgbase="php${_phpbase}${_suffix}"
pkgdesc="PHP ${pkgver} compiled as to not conflict with mainline php"
_cppflags=" -DU_USING_ICU_NAMESPACE=1 "
@@ -95,6 +95,7 @@ _build_per_sapi="0"
_build_phpdbg="1"
_build_recode="0"
_build_shared_gd="1"
+_build_shared_mysqlnd="0"
_build_sodium="1"
_build_static_pdo="0"
_build_uses_autoconf="1"
@@ -133,7 +134,6 @@ _phpextensions="\
--enable-sysvsem=shared \
--enable-sysvshm=shared \
--enable-tokenizer=shared \
- --enable-mysqlnd=shared \
--enable-mysqlnd-compression-support \
--with-mysqli=shared,mysqlnd \
--with-pdo-mysql=shared,mysqlnd \
@@ -166,6 +166,7 @@ _phpextensions="\
--with-ldap-sasl \
--with-pdo-sqlite=shared,/usr \
--with-sqlite3=shared \
+ --enable-mysqlnd \
--enable-gd=shared \
--with-external-gd=/usr \
--with-jpeg \
@@ -219,6 +220,7 @@ makedepends=(
'libxslt' 'libzip' 'freetds' 'apache' 'aspell' 'c-client' 'db' 'enchant' 'readline'
'gmp' 'icu' 'net-snmp' 'postgresql-libs' 'sqlite' 'systemd-libs' 'unixodbc' 'curl' 'ncurses'
'freetds' 'pcre' 'tidy' 'libfbclient' 'oniguruma' 'gd' 'recode' 'bzip2' 'gdbm' 'zlib'
+ 'systemd' 'systemd-libs'
)
arch=('i686' 'x86_64')
checkdepends=('procps-ng')
@@ -433,9 +435,9 @@ build() {
}
check() {
- pushd "php-${pkgver}"
+ pushd "build"
# Check if sendmail was configured correctly (FS#47600)
- ../build/sapi/cli/php -n -r 'echo ini_get("sendmail_path");' | grep -q '/usr/bin/sendmail'
+ sapi/cli/php -n -r 'echo ini_get("sendmail_path");' | grep -q '/usr/bin/sendmail'
export REPORT_EXIT_STATUS=1
export NO_INTERACTION=1
@@ -443,10 +445,10 @@ check() {
export SKIP_SLOW_TESTS=1
if ((_phpbase <= 54)); then
- TEST_PHP_EXECUTABLE="../build/sapi/cli/php" \
- ../build/sapi/cli/php -n run-tests.php -n {tests,Zend}
+ TEST_PHP_EXECUTABLE="sapi/cli/php" \
+ sapi/cli/php -n run-tests.php -n {tests,Zend}
elif ((_phpbase >= 55 && _phpbase < 73)); then
- ../build/sapi/cli/php -n run-tests.php -n -P {tests,Zend}
+ sapi/cli/php -n run-tests.php -n -P {tests,Zend}
elif ((73 == _phpbase)); then
export TESTS='tests Zend'
make test
@@ -969,7 +971,9 @@ package_php81-interbase() {
package_php81-mysql() {
pkgdesc="MySQL modules for php${_phpbase}${_suffix}"
depends=("php${_phpbase}${_suffix}")
- _install_module mysqlnd
+ if ((_build_shared_mysqlnd)); then
+ _install_module mysqlnd
+ fi
_install_module mysqli
_install_module pdo_mysql
if ((_build_outdated_mysql)); then