summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEugene Lamskoy2024-04-18 21:23:18 +0300
committerEugene Lamskoy2024-04-18 21:23:18 +0300
commit879787f61daf7938a55f829784d0c08936e28409 (patch)
treeef0fba2e70c6b88e1a7c104f8812528cc1ed73fc
downloadaur-879787f61daf7938a55f829784d0c08936e28409.tar.gz
Initial version
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD38
3 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8d63340cd111
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = php83-igbinary
+ pkgdesc = php83 extension igbinary
+ pkgver = 3.2.15
+ pkgrel = 1
+ url = http://pecl.php.net/package/igbinary
+ arch = x86_64
+ license = PHP
+ makedepends = php83
+ depends = php83
+ backup = etc/php83/conf.d/igbinary.ini
+ source = http://pecl.php.net/get/igbinary-3.2.15.tgz
+ md5sums = de81e2f54bfbe741a7f2453bccf970e9
+
+pkgname = php83-igbinary
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..95257c5aac52
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+*.tar.xz
+*.tar.gz
+*.tar.bz2
+*.tgz
+*.tar.*
+pkg/
+src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0dd37518aa32
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+_phpbase=83
+_suffix=
+pkgname="php${_phpbase}-igbinary"
+_pkgname=igbinary
+pkgver=3.2.15
+pkgrel=1
+pkgdesc="php${_phpbase} extension igbinary"
+url="http://pecl.php.net/package/igbinary"
+arch=('x86_64')
+license=('PHP')
+makedepends=("php${_phpbase}${_suffix}")
+depends=("php${_phpbase}${_suffix}")
+backup=("etc/php${_phpbase}/conf.d/${_pkgname}.ini")
+source=("http://pecl.php.net/get/${_pkgname}-${pkgver}.tgz")
+md5sums=('de81e2f54bfbe741a7f2453bccf970e9')
+
+build() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ phpize${_phpbase}
+ ./configure --prefix=/usr CFLAGS="-O2 -g" --enable-igbinary --with-php-config=php-config${_phpbase}
+ make
+}
+
+check() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ NO_INTERACTION=1 make test
+}
+
+package() {
+ cd "$srcdir/igbinary-$pkgver"
+ make INSTALL_ROOT="$pkgdir" install
+ install -D -m0644 \
+ "${srcdir}/${_pkgname}-${pkgver}/${_pkgname}.php.ini" \
+ "${pkgdir}/etc/php${_phpbase}/conf.d/${_pkgname}.ini"
+ install -D -m0644 \
+ "${srcdir}/${_pkgname}-${pkgver}/COPYING" \
+ "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}