summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStefan Auditor2015-10-04 10:19:22 +0200
committerStefan Auditor2015-10-04 10:19:22 +0200
commit2d3ce56569849a682dff545702ffae0641838940 (patch)
tree3a050ffe44f70aca343451e7e03a47c484f2d990
downloadaur-2d3ce56569849a682dff545702ffae0641838940.tar.gz
Initial release for upstream 2.0.1
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD21
-rw-r--r--phpcov.install9
3 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5c2575b856a8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = phpcov
+ pkgdesc = A command-line frontend for the PHP_CodeCoverage library.
+ pkgver = 2.0.1
+ pkgrel = 1
+ url = https://github.com/sebastianbergmann/phpcov
+ install = phpcov.install
+ arch = any
+ license = BSD
+ depends = php
+ source = https://phar.phpunit.de/phpcov-2.0.1.phar
+ source = https://raw.githubusercontent.com/sebastianbergmann/phpcov/2.0.1/LICENSE
+ sha512sums = 69f2eaea1f07a8e0b5b894fc30458513cadcdfdfb63392c0dfcc314594b9fa34b1d5d47c60c81ca41f96eb540dfe96040bc3e1e68226f8aabfe0ccc62a00e7a0
+ sha512sums = 67251aea87ad2056acf0bb57b7e80011c428895f9c61c5016be7e1fea51bbe6b9c6b726928c584a35c6bc02d67a2b8372fcc32a4d4480dfd1b7bf5d62ca83b9a
+
+pkgname = phpcov
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9086a5c397a4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Stefan Auditor <stefan.auditor@erdfisch.de>
+pkgname=phpcov
+pkgver=2.0.1
+pkgrel=1
+pkgdesc="A command-line frontend for the PHP_CodeCoverage library."
+url="https://github.com/sebastianbergmann/phpcov"
+arch=("any")
+license=("BSD")
+depends=("php")
+install="${pkgname}.install"
+source=("https://phar.phpunit.de/${pkgname}-${pkgver}.phar"
+ "https://raw.githubusercontent.com/sebastianbergmann/${pkgname}/${pkgver}/LICENSE")
+sha512sums=('69f2eaea1f07a8e0b5b894fc30458513cadcdfdfb63392c0dfcc314594b9fa34b1d5d47c60c81ca41f96eb540dfe96040bc3e1e68226f8aabfe0ccc62a00e7a0'
+ '67251aea87ad2056acf0bb57b7e80011c428895f9c61c5016be7e1fea51bbe6b9c6b726928c584a35c6bc02d67a2b8372fcc32a4d4480dfd1b7bf5d62ca83b9a')
+
+package() {
+ install -D -m 644 "${srcdir}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -D -m 755 "${srcdir}/${pkgname}-${pkgver}.phar" "${pkgdir}/usr/share/webapps/bin/${pkgname}.phar"
+ install -d "${pkgdir}/usr/bin"
+ ln -s "/usr/share/webapps/bin/${pkgname}.phar" "${pkgdir}/usr/bin/${pkgname}"
+}
diff --git a/phpcov.install b/phpcov.install
new file mode 100644
index 000000000000..e98ff10b1b95
--- /dev/null
+++ b/phpcov.install
@@ -0,0 +1,9 @@
+post_install() {
+ echo
+ echo "Warning: phar.so must be enabled and date.timezone set in your php.ini"
+ echo "Note: You should load /usr/share/webapps/bin/phpunit.phar in your IDE"
+}
+
+post_upgrade() {
+ post_install
+}