summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohannes Schleifenbaum2014-12-30 10:50:45 +0100
committerJohannes Schleifenbaum2014-12-30 10:50:45 +0100
commit0c2798f48d6a020ba3aa9c3a083f47cff5787800 (patch)
tree25bb5c11766aef473367a42a6625b673e843be90
downloadaur-0c2798f48d6a020ba3aa9c3a083f47cff5787800.tar.gz
all packages in aur subfolder
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore6
-rw-r--r--LICENSE33
-rw-r--r--PKGBUILD31
4 files changed, 87 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..68fd2c2a4d32
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = phpcpd
+ pkgdesc = Copy/Paste Detector (CPD) for PHP code.
+ pkgver = 2.0.1
+ pkgrel = 3
+ url = https://github.com/sebastianbergmann/phpcpd
+ arch = any
+ license = BSD
+ depends = php>=5.3.3
+ source = https://phar.phpunit.de/phpcpd-2.0.1.phar
+ source = LICENSE
+ sha1sums = f9fb98b688092603adff5ca0f1264fcf77674f90
+ sha1sums = 6e7d5c0718a2559eb09bd1456606cd1d5ac90dc7
+ sha256sums = 3060ec805184c4cc31c45a81d456f74dcca9ca05efa662442ef9bf74ffa86e7c
+ sha256sums = b107a0992a839dfb3eee3844d7d680fa62dcc37a5b496ae987b695ad86976e02
+
+pkgname = phpcpd
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..6010e1b4afac
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+*.pkg.*
+pkg/
+src/
+*.pkg.*.sig
+*.src.tar.gz
+*.phar
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..9efaa72e49ce
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,33 @@
+phpcpd
+
+Copyright (c) 2009-2014, Sebastian Bergmann <sebastian@phpunit.de>.
+All rights reserved.
+
+Redistribution and use in source and binary forms, with or without
+modification, are permitted provided that the following conditions
+are met:
+
+ * Redistributions of source code must retain the above copyright
+ notice, this list of conditions and the following disclaimer.
+
+ * Redistributions in binary form must reproduce the above copyright
+ notice, this list of conditions and the following disclaimer in
+ the documentation and/or other materials provided with the
+ distribution.
+
+ * Neither the name of Sebastian Bergmann nor the names of his
+ contributors may be used to endorse or promote products derived
+ from this software without specific prior written permission.
+
+THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
+"AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
+LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
+FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE
+COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT,
+INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING,
+BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES;
+LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER
+CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT
+LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN
+ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE
+POSSIBILITY OF SUCH DAMAGE. \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0f0741e94c24
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Johannes Schleifenbaum <johannes [at] js-webcoding [dot] de>
+# Please report issues at https://github.com/jojosch/pkgbuilds
+
+pkgname="phpcpd"
+pkgver=2.0.1
+pkgrel=3
+pkgdesc="Copy/Paste Detector (CPD) for PHP code."
+url="https://github.com/sebastianbergmann/phpcpd"
+license="BSD"
+arch=("any")
+depends=("php>=5.3.3")
+source=(
+ "https://phar.phpunit.de/${pkgname}-${pkgver}.phar"
+ "LICENSE"
+)
+sha1sums=(
+ "f9fb98b688092603adff5ca0f1264fcf77674f90"
+ "6e7d5c0718a2559eb09bd1456606cd1d5ac90dc7"
+)
+sha256sums=(
+ "3060ec805184c4cc31c45a81d456f74dcca9ca05efa662442ef9bf74ffa86e7c"
+ "b107a0992a839dfb3eee3844d7d680fa62dcc37a5b496ae987b695ad86976e02"
+)
+
+package() {
+ cd "${srcdir}"
+ install -D -m644 "LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -D -m755 "${pkgname}-${pkgver}.phar" "${pkgdir}/usr/share/webapps/bin/${pkgname}.phar"
+ install -d "${pkgdir}/usr/bin"
+ ln -s "/usr/share/webapps/bin/${pkgname}.phar" "${pkgdir}/usr/bin/${pkgname}"
+}