summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Vogt2015-12-16 15:45:39 +0100
committerDavid Vogt2015-12-16 15:45:39 +0100
commit1ddd903a9b8e9e938602e5f9ba84c003f5592c3f (patch)
treeaf271e35efda5c744465a7d11155c28dfb473536
downloadaur-1ddd903a9b8e9e938602e5f9ba84c003f5592c3f.tar.gz
Initial version
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD27
-rw-r--r--phpctags.install8
4 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..801d406d6ed7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = phpctags
+ pkgdesc = A script to help you manage your notes and access them quickly
+ pkgver = 0.5.1
+ pkgrel = 0
+ url = https://github.com/winged/notevim
+ install = phpctags.install
+ arch = x86_64
+ arch = i686
+ license = GPLv2
+ depends = php
+ provides = phpctags
+ source = http://vim-php.com/phpctags/install/phpctags.phar
+ sha256sums = 6e6c59cf0b45832dd5e3a01d2c6cfade5eeaad30daa46db48e74f2ecaa6fbaaa
+
+pkgname = phpctags
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f59378ad4400
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+phpctags-*.pkg.tar*
+phpctags.phar
+/pkg/
+/src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..668aa7de16e5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: David Vogt <dave at winged dot ch>
+# This PKGBUILD is maintained at https://github.com/winged/aur-packages
+
+pkgname=phpctags
+pkgver=0.5.1
+pkgrel=0
+pkgdesc="A script to help you manage your notes and access them quickly"
+arch=('x86_64' 'i686')
+license=('GPLv2')
+url=('https://github.com/winged/notevim')
+depends=('php')
+provides=('phpctags')
+conflicts=()
+optdepends=()
+
+install=('phpctags.install')
+
+source=("http://vim-php.com/phpctags/install/phpctags.phar")
+sha256sums=('6e6c59cf0b45832dd5e3a01d2c6cfade5eeaad30daa46db48e74f2ecaa6fbaaa')
+
+package() {
+ mkdir -p "$pkgdir/usr/bin"
+ mkdir -p "$pkgdir/etc/php/conf.d"
+ install phpctags.phar "$pkgdir/usr/bin/phpctags"
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/phpctags.install b/phpctags.install
new file mode 100644
index 000000000000..d79eb5ad3081
--- /dev/null
+++ b/phpctags.install
@@ -0,0 +1,8 @@
+#!/bin/sh
+
+post_install() {
+ echo "NOTE: you may need update your /etc/php/php.ini for this to work!"
+ echo " The following changes are needed:"
+ echo " - Make sure the extension phar.so is activated"
+ echo " - Disable open_basedir restriction"
+}