summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Vogt2017-01-20 14:14:17 +0100
committerDavid Vogt2017-01-20 14:14:17 +0100
commitb1834839a71168c8d865d093dc009ffa336c13e8 (patch)
tree77f99e27ef4e04be946c6c2f3408d2409abdfa24
parentea63b7b6936710f63ac971a666334e3e5bf58605 (diff)
downloadaur-b1834839a71168c8d865d093dc009ffa336c13e8.tar.gz
Bump to version 0.6.0
Note that the --help text and possibly some other things are very broken upstream (like containing merge conflict data). This must be fixed upstream. I am still packaging it like this because the main functionality seems to work correctly still.
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD11
2 files changed, 10 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4008901c32d9..6dcf66229280 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = phpctags
pkgdesc = An enhanced PHP ctags index generator
- pkgver = 0.5.1
+ pkgver = 0.6.0
pkgrel = 1
url = https://packagist.org/packages/techlivezheng/phpctags
install = phpctags.install
@@ -8,8 +8,8 @@ pkgbase = phpctags
license = GPLv2
depends = php
provides = phpctags
- source = http://vim-php.com/phpctags/install/phpctags.phar
- sha256sums = 6e6c59cf0b45832dd5e3a01d2c6cfade5eeaad30daa46db48e74f2ecaa6fbaaa
+ source = https://github.com/vim-php/phpctags/archive/0.6.0.zip
+ sha256sums = 0d995dc1c432b7b451b5e2cd03064047d5b30939f9b05b994a4630ea537a5afe
pkgname = phpctags
diff --git a/PKGBUILD b/PKGBUILD
index f0d724aae41a..5cb3e81a3bf8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# This PKGBUILD is maintained at https://github.com/winged/aur-packages
pkgname=phpctags
-pkgver=0.5.1
+pkgver=0.6.0
pkgrel=1
pkgdesc="An enhanced PHP ctags index generator"
arch=('any')
@@ -15,11 +15,14 @@ optdepends=()
install='phpctags.install'
-source=("http://vim-php.com/phpctags/install/phpctags.phar")
-sha256sums=('6e6c59cf0b45832dd5e3a01d2c6cfade5eeaad30daa46db48e74f2ecaa6fbaaa')
+source=("https://github.com/vim-php/phpctags/archive/$pkgver.zip")
+sha256sums=('0d995dc1c432b7b451b5e2cd03064047d5b30939f9b05b994a4630ea537a5afe')
package() {
- install -Dm755 phpctags.phar "$pkgdir/usr/bin/phpctags"
+ cd $pkgname-$pkgver
+ ls -aslh
+ make
+ install -Dm755 build/phpctags.phar "$pkgdir/usr/bin/phpctags"
}
# vim:set ts=2 sw=2 et: