summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohannes Schleifenbaum2014-12-30 10:50:45 +0100
committerJohannes Schleifenbaum2014-12-30 10:50:45 +0100
commit8b5b4fe89ff9b2bbc9c2a6d5d3ce988ddbe1b1f1 (patch)
tree11b6ac6410b431c030dbabc55e8c1e009905e66e
downloadaur-8b5b4fe89ff9b2bbc9c2a6d5d3ce988ddbe1b1f1.tar.gz
all packages in aur subfolder
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore6
-rw-r--r--LICENSE33
-rw-r--r--PKGBUILD31
4 files changed, 87 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a0cbd6133bd9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = phpdcd
+ pkgdesc = Dead Code Detector (DCD) for PHP code.
+ pkgver = 1.0.2
+ pkgrel = 3
+ url = https://github.com/sebastianbergmann/phpdcd
+ arch = any
+ license = BSD
+ depends = php>=5.3.3
+ source = https://phar.phpunit.de/phpdcd-1.0.2.phar
+ source = LICENSE
+ sha1sums = f2052a9c143d79057257497e5fcf3c7275ebd065
+ sha1sums = 11946e2ec7349724cf1cd711cd7fddf2dae82475
+ sha256sums = 28301205d671a6e564e72c5b249ef31600d1fdda6958b35bd2a9b2e0f2f54ede
+ sha256sums = fc0ec35ca43801ccb61680b806558bae66301750e25046c7b5633c239855a87d
+
+pkgname = phpdcd
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..6010e1b4afac
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+*.pkg.*
+pkg/
+src/
+*.pkg.*.sig
+*.src.tar.gz
+*.phar
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..1b682af93480
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,33 @@
+phpdcd
+
+Copyright (c) 2009-2014, Sebastian Bergmann <sebastian@phpunit.de>.
+All rights reserved.
+
+Redistribution and use in source and binary forms, with or without
+modification, are permitted provided that the following conditions
+are met:
+
+ * Redistributions of source code must retain the above copyright
+ notice, this list of conditions and the following disclaimer.
+
+ * Redistributions in binary form must reproduce the above copyright
+ notice, this list of conditions and the following disclaimer in
+ the documentation and/or other materials provided with the
+ distribution.
+
+ * Neither the name of Sebastian Bergmann nor the names of his
+ contributors may be used to endorse or promote products derived
+ from this software without specific prior written permission.
+
+THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
+"AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
+LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
+FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE
+COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT,
+INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING,
+BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES;
+LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER
+CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT
+LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN
+ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE
+POSSIBILITY OF SUCH DAMAGE. \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..82575d36c2f5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Johannes Schleifenbaum <johannes [at] js-webcoding [dot] de>
+# Please report issues at https://github.com/jojosch/pkgbuilds
+
+pkgname="phpdcd"
+pkgver=1.0.2
+pkgrel=3
+pkgdesc="Dead Code Detector (DCD) for PHP code."
+url="https://github.com/sebastianbergmann/phpdcd"
+license="BSD"
+arch=("any")
+depends=("php>=5.3.3")
+source=(
+ "https://phar.phpunit.de/${pkgname}-${pkgver}.phar"
+ "LICENSE"
+)
+sha1sums=(
+ "f2052a9c143d79057257497e5fcf3c7275ebd065"
+ "11946e2ec7349724cf1cd711cd7fddf2dae82475"
+)
+sha256sums=(
+ "28301205d671a6e564e72c5b249ef31600d1fdda6958b35bd2a9b2e0f2f54ede"
+ "fc0ec35ca43801ccb61680b806558bae66301750e25046c7b5633c239855a87d"
+)
+
+package() {
+ cd "${srcdir}"
+ install -D -m644 "LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -D -m755 "${pkgname}-${pkgver}.phar" "${pkgdir}/usr/share/webapps/bin/${pkgname}.phar"
+ install -d "${pkgdir}/usr/bin"
+ ln -s "/usr/share/webapps/bin/${pkgname}.phar" "${pkgdir}/usr/bin/${pkgname}"
+}