summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormst2015-06-11 13:28:41 +0200
committermst2015-06-11 13:28:41 +0200
commitd6f3f931309d360749bf6bc55fc0a97ee8c4e2fb (patch)
tree5c729a71f35c4b0d28540ef6de224bfc6648d463
downloadaur-d6f3f931309d360749bf6bc55fc0a97ee8c4e2fb.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--LICENSE31
-rw-r--r--PKGBUILD24
-rw-r--r--phpdox.install4
4 files changed, 76 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5d33d4d39b86
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = phpdox
+ pkgdesc = Documentation generator for PHP Code using standard technology (SRC, DOCBLOCK, XML and XSLT)
+ pkgver = 0.8.0
+ pkgrel = 1
+ url = http://phpdox.de
+ install = phpdox.install
+ arch = any
+ license = custom
+ depends = php>=5.3.3
+ depends = php-xsl
+ source = https://github.com/theseer/phpdox/releases/download/0.8.0/phpdox-0.8.0.phar
+ source = LICENSE
+ sha256sums = be4627f7891dffd4ce1cc0e27f98993c17bbaa35bd950e1f7f66cc6a411f14a8
+ sha256sums = b9f0017ad3f5fcb80fd561870543fe92ac89a65dbd14e759f6be93b25670250a
+
+pkgname = phpdox
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..39e1b99b7f4d
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,31 @@
+phpDox
+
+Copyright (c) 2010-2015 Arne Blankerts <arne@blankerts.de>
+All rights reserved.
+
+Redistribution and use in source and binary forms, with or without modification,
+are permitted provided that the following conditions are met:
+
+* Redistributions of source code must retain the above copyright notice,
+ this list of conditions and the following disclaimer.
+
+* Redistributions in binary form must reproduce the above copyright notice,
+ this list of conditions and the following disclaimer in the documentation
+ and/or other materials provided with the distribution.
+
+* Neither the name of Arne Blankerts nor the names of contributors
+ may be used to endorse or promote products derived from this software
+ without specific prior written permission.
+
+THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS"
+AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT * NOT LIMITED TO,
+THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
+PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDER ORCONTRIBUTORS
+BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY,
+OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
+SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS
+INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN
+CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE)
+ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE
+POSSIBILITY OF SUCH DAMAGE.
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..970a1547019e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Marc Straube <m.straube@skunk-coding.de>>
+
+pkgname='phpdox'
+pkgver='0.8.0'
+pkgrel=1
+pkgdesc="Documentation generator for PHP Code using standard technology (SRC, DOCBLOCK, XML and XSLT)"
+url="http://phpdox.de"
+license=('custom')
+install="${pkgname}.install"
+arch=('any')
+depends=('php>=5.3.3' 'php-xsl')
+source=("https://github.com/theseer/${pkgname}/releases/download/${pkgver}/${pkgname}-${pkgver}.phar"
+ 'LICENSE')
+sha256sums=('be4627f7891dffd4ce1cc0e27f98993c17bbaa35bd950e1f7f66cc6a411f14a8'
+ 'b9f0017ad3f5fcb80fd561870543fe92ac89a65dbd14e759f6be93b25670250a')
+
+package() {
+ cd "${srcdir}"
+
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -D -m755 "${pkgname}-${pkgver}.phar" "${pkgdir}/usr/share/webapps/bin/${pkgname}.phar"
+ install -d "${pkgdir}/usr/bin"
+ ln -s "/usr/share/webapps/bin/${pkgname}.phar" "${pkgdir}/usr/bin/${pkgname}"
+}
diff --git a/phpdox.install b/phpdox.install
new file mode 100644
index 000000000000..2001c1b7ff58
--- /dev/null
+++ b/phpdox.install
@@ -0,0 +1,4 @@
+post_install()
+{
+ echo "Please activate the extensions 'iconv', 'phar' and 'xsl' in your php.ini."
+}