summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorasukaminato2023-06-18 14:01:23 +0900
committerasukaminato2023-06-18 14:01:23 +0900
commite6c96470ed7280199c7978e7cb15a69f4eede8b6 (patch)
treead9aa846b52e6de29ebe2a70a4989878e1ba846b
downloadaur-e6c96470ed7280199c7978e7cb15a69f4eede8b6.tar.gz
init
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore13
-rw-r--r--PKGBUILD36
3 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..dbb4c58ffa0b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = phpgrep-bin
+ pkgdesc = Syntax-aware grep for PHP code.
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/quasilyte/phpgrep
+ arch = x86_64
+ arch = aarch64
+ license = MIT
+ provides = phpgrep
+ source_x86_64 = https://github.com/quasilyte/phpgrep/releases/download/v1.0.0/phpgrep-1.0.0-linux-amd64.zip
+ sha256sums_x86_64 = 4b40e758e9cef0c4ed2e31eaa1b5834c9f415808a68114f993efbbe53dcfb9e3
+ source_aarch64 = https://github.com/quasilyte/phpgrep/releases/download/v1.0.0/phpgrep-1.0.0-linux-arm64.zip
+ sha256sums_aarch64 = d02c6a3b775bff2248cbb0b06623bf7afb5f7a268c936239b6bc2079721a10eb
+
+pkgname = phpgrep-bin
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..b73905529f23
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,13 @@
+*.tar
+*.tar.*
+*.jar
+*.exe
+*.msi
+*.zip
+*.tgz
+*.log
+*.log.*
+*.sig
+
+pkg/
+src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9bc3d76493e7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Maintainer: Your Name <youremail@domain.com>
+pkgname=phpgrep-bin
+pkgver=1.0.0
+pkgrel=1
+epoch=
+pkgdesc="Syntax-aware grep for PHP code."
+arch=(x86_64 aarch64)
+url="https://github.com/quasilyte/phpgrep"
+license=('MIT')
+groups=()
+depends=()
+makedepends=()
+checkdepends=()
+optdepends=()
+provides=(phpgrep)
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source_x86_64=("https://github.com/quasilyte/phpgrep/releases/download/v1.0.0/phpgrep-1.0.0-linux-amd64.zip")
+source_aarch64=("https://github.com/quasilyte/phpgrep/releases/download/v1.0.0/phpgrep-1.0.0-linux-arm64.zip")
+noextract=()
+sha256sums_x86_64=('4b40e758e9cef0c4ed2e31eaa1b5834c9f415808a68114f993efbbe53dcfb9e3')
+sha256sums_aarch64=('d02c6a3b775bff2248cbb0b06623bf7afb5f7a268c936239b6bc2079721a10eb')
+validpgpkeys=()
+
+package() {
+ install -Dm755 phpgrep -t "$pkgdir"/usr/bin/
+}