summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVirtualTam2015-07-13 02:40:41 +0200
committerVirtualTam2015-07-13 02:42:00 +0200
commit63a734a7f66f92310b7004b068398392167d92c9 (patch)
treec9efae950b29c870deda3387efcccf2b5c726f52
downloadaur-63a734a7f66f92310b7004b068398392167d92c9.tar.gz
Initial import of phplint11 1.1_20130803
Signed-off-by: VirtualTam <virtualtam@flibidi.net>
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD39
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..28c5f9a54c3c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = phplint11
+ pkgdesc = PHP 4 and 5 validator and documentator.
+ pkgver = 1.1_20130803
+ pkgrel = 2
+ url = http://www.icosaedro.it/phplint/
+ arch = i686
+ arch = x86_64
+ license = MIT
+ depends = gc
+ source = http://www.icosaedro.it/phplint//phplint11-pure-c-1.1_20130803.tar.gz
+ md5sums = 6c7b80444adaa31a5005b1b816d0cfda
+
+pkgname = phplint11
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bb528d950b8f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: VirtualTam <virtualtam@flibidi.net>
+# Contributor: Alexandre Boily <alexandreboily@gmail.com>
+#
+# NOTE
+# The latest version, 2.0_20140824, can be installed with Composer:
+#
+# pacman -S php-composer
+# composer global require phplint/phplint
+pkgname=phplint11
+pkgdesc="PHP 4 and 5 validator and documentator."
+pkgver=1.1_20130803
+pkgrel=2
+arch=('i686' 'x86_64')
+url='http://www.icosaedro.it/phplint/'
+license=('MIT')
+depends=('gc')
+source=("${url}/${pkgname}-pure-c-${pkgver}.tar.gz")
+md5sums=('6c7b80444adaa31a5005b1b816d0cfda')
+
+build() {
+ ### Compile
+ cd "${srcdir}/${pkgbase}-pure-c-${pkgver}"
+ ./configure
+ ./compile || return 1
+}
+
+package() {
+ cd "${srcdir}/${pkgbase}-pure-c-${pkgver}"
+
+ ### Create the paths and copy files
+ mkdir -p ${pkgdir}/usr/share/phplint/
+ mkdir -p ${pkgdir}/usr/share/licences/phplint/
+ mkdir -p ${pkgdir}/usr/bin/
+ cp ${srcdir}/${pkgbase}-pure-c-${pkgver}/src/phplint ${pkgdir}/usr/bin/
+ cp -R ${srcdir}/${pkgbase}-pure-c-${pkgver}/modules ${pkgdir}/usr/share/phplint/
+
+ ### Change the rights for module files
+ chmod a+r ${pkgdir}/usr/share/phplint/modules/*
+}