summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorD. Can Celasun2018-04-18 09:53:57 +0200
committerD. Can Celasun2018-04-18 09:53:57 +0200
commitfdd8bb95cf189b5073e898fe948c8531ff167c9d (patch)
treeb6357b25e8b8eb71a4742c745495bf4336a8c2a7
parent8f02f5d6952ccd979da0fc854fd66b4be4857109 (diff)
parente9e3292b9023c716b7090e314f63aeecbb14d5d8 (diff)
downloadaur-fdd8bb95cf189b5073e898fe948c8531ff167c9d.tar.gz
Merge subtree 'phpredis-git'
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD9
2 files changed, 7 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0270b7661d23..81534a72b981 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -4,14 +4,14 @@ pkgbase = phpredis-git
pkgdesc = A PHP extension for Redis
pkgver = 3.1.4RC1.r139.g18d03fd
pkgrel = 1
- url = https://github.com/nicolasff/phpredis
+ url = https://github.com/phpredis/phpredis
arch = i686
arch = x86_64
license = PHP
makedepends = git
depends = php
backup = etc/php/conf.d/phpredis.ini
- source = git+https://github.com/nicolasff/phpredis.git
+ source = git+https://github.com/phpredis/phpredis.git
source = phpredis.ini
md5sums = SKIP
md5sums = 1fc22a23c6b24a223dd235a15d5e194f
diff --git a/PKGBUILD b/PKGBUILD
index 6247fc8f6481..c95f5750fe9b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,14 +5,16 @@ pkgrel=1
pkgver=3.1.4RC1.r139.g18d03fd
pkgdesc="A PHP extension for Redis"
arch=('i686' 'x86_64')
-url="https://github.com/nicolasff/phpredis"
+url="https://github.com/phpredis/phpredis"
license=('PHP')
makedepends=('git')
depends=('php')
_ininame="phpredis.ini"
_inifile="etc/php/conf.d/$_ininame"
+provides=("php-redis")
+conflicts=("php-redis")
backup=("$_inifile")
-source=(git+https://github.com/nicolasff/phpredis.git ${_ininame})
+source=(git+https://github.com/phpredis/phpredis.git ${_ininame})
md5sums=('SKIP'
'1fc22a23c6b24a223dd235a15d5e194f')
@@ -26,14 +28,13 @@ build() {
cd "${srcdir}/phpredis"
phpize
- ./configure --prefix=/usr --enable-redis
+ ./configure --prefix=/usr
make
TEST_PHP_ARGS="-q" make test
}
package() {
cd "${srcdir}/phpredis"
-
make INSTALL_ROOT="${pkgdir}" install
install -vDm644 "${srcdir}/${_ininame}" "${pkgdir}/${_inifile}"
}