summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormax2023-04-02 15:38:09 +0200
committermax2023-04-02 15:38:17 +0200
commit542d08db76aea977ceea10fc8954073d653bf0cf (patch)
tree8d4c2576311fbcd24f30f34a31c6db13d79621d6
parent87ce82da27046d137c69f49adb93d251b4cc6bc7 (diff)
downloadaur-542d08db76aea977ceea10fc8954073d653bf0cf.tar.gz
Release 10.0.19
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rw-r--r--composer.lock53
3 files changed, 31 insertions, 30 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f70643353578..3f536114ec56 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = phpunit
pkgdesc = PHPUnit is a programmer-oriented testing framework for PHP.
- pkgver = 10.0.14
+ pkgver = 10.0.19
pkgrel = 1
url = https://phpunit.de
install = phpunit.install
@@ -11,7 +11,7 @@ pkgbase = phpunit
makedepends = composer
depends = php>=8.1.0
conflicts = phpunit-bin
- source = git+https://github.com/sebastianbergmann/phpunit.git#tag=10.0.14
+ source = git+https://github.com/sebastianbergmann/phpunit.git#tag=10.0.19
source = composer.lock
sha256sums = SKIP
sha256sums = f30e3c7e14f92fe4031ffd766be364edac9e61584ee67dfa891d24e1c88c69ee
diff --git a/PKGBUILD b/PKGBUILD
index e644301250ba..f0c4e717d8a8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
_pkgname=phpunit
pkgname=${_pkgname}
-pkgver=10.0.14
+pkgver=10.0.19
pkgrel=1
pkgdesc="PHPUnit is a programmer-oriented testing framework for PHP."
conflicts=('phpunit-bin')
@@ -18,7 +18,7 @@ install="${_pkgname}.install"
source=("git+https://github.com/sebastianbergmann/phpunit.git#tag=${pkgver}"
"composer.lock")
sha256sums=('SKIP'
- 'f30e3c7e14f92fe4031ffd766be364edac9e61584ee67dfa891d24e1c88c69ee')
+ '2503b9fc9042a12d9731727a5590c9094316ee89b4fe8ea4452ae11040a70243')
prepare() {
cd ${_pkgname}
diff --git a/composer.lock b/composer.lock
index 034942d9d0cf..d1be9e77b151 100644
--- a/composer.lock
+++ b/composer.lock
@@ -8,16 +8,16 @@
"packages": [
{
"name": "myclabs/deep-copy",
- "version": "1.11.0",
+ "version": "1.11.1",
"source": {
"type": "git",
"url": "https://github.com/myclabs/DeepCopy.git",
- "reference": "14daed4296fae74d9e3201d2c4925d1acb7aa614"
+ "reference": "7284c22080590fb39f2ffa3e9057f10a4ddd0e0c"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/myclabs/DeepCopy/zipball/14daed4296fae74d9e3201d2c4925d1acb7aa614",
- "reference": "14daed4296fae74d9e3201d2c4925d1acb7aa614",
+ "url": "https://api.github.com/repos/myclabs/DeepCopy/zipball/7284c22080590fb39f2ffa3e9057f10a4ddd0e0c",
+ "reference": "7284c22080590fb39f2ffa3e9057f10a4ddd0e0c",
"shasum": ""
},
"require": {
@@ -55,7 +55,7 @@
],
"support": {
"issues": "https://github.com/myclabs/DeepCopy/issues",
- "source": "https://github.com/myclabs/DeepCopy/tree/1.11.0"
+ "source": "https://github.com/myclabs/DeepCopy/tree/1.11.1"
},
"funding": [
{
@@ -63,20 +63,20 @@
"type": "tidelift"
}
],
- "time": "2022-03-03T13:19:32+00:00"
+ "time": "2023-03-08T13:26:56+00:00"
},
{
"name": "nikic/php-parser",
- "version": "v4.15.3",
+ "version": "v4.15.4",
"source": {
"type": "git",
"url": "https://github.com/nikic/PHP-Parser.git",
- "reference": "570e980a201d8ed0236b0a62ddf2c9cbb2034039"
+ "reference": "6bb5176bc4af8bcb7d926f88718db9b96a2d4290"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/nikic/PHP-Parser/zipball/570e980a201d8ed0236b0a62ddf2c9cbb2034039",
- "reference": "570e980a201d8ed0236b0a62ddf2c9cbb2034039",
+ "url": "https://api.github.com/repos/nikic/PHP-Parser/zipball/6bb5176bc4af8bcb7d926f88718db9b96a2d4290",
+ "reference": "6bb5176bc4af8bcb7d926f88718db9b96a2d4290",
"shasum": ""
},
"require": {
@@ -117,9 +117,9 @@
],
"support": {
"issues": "https://github.com/nikic/PHP-Parser/issues",
- "source": "https://github.com/nikic/PHP-Parser/tree/v4.15.3"
+ "source": "https://github.com/nikic/PHP-Parser/tree/v4.15.4"
},
- "time": "2023-01-16T22:05:37+00:00"
+ "time": "2023-03-05T19:49:14+00:00"
},
{
"name": "phar-io/manifest",
@@ -234,16 +234,16 @@
},
{
"name": "phpunit/php-code-coverage",
- "version": "10.0.1",
+ "version": "10.0.2",
"source": {
"type": "git",
"url": "https://github.com/sebastianbergmann/php-code-coverage.git",
- "reference": "b9c21a93dd8c8eed79879374884ee733259475cc"
+ "reference": "20800e84296ea4732f9a125e08ce86b4004ae3e4"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/sebastianbergmann/php-code-coverage/zipball/b9c21a93dd8c8eed79879374884ee733259475cc",
- "reference": "b9c21a93dd8c8eed79879374884ee733259475cc",
+ "url": "https://api.github.com/repos/sebastianbergmann/php-code-coverage/zipball/20800e84296ea4732f9a125e08ce86b4004ae3e4",
+ "reference": "20800e84296ea4732f9a125e08ce86b4004ae3e4",
"shasum": ""
},
"require": {
@@ -265,8 +265,8 @@
"phpunit/phpunit": "^10.0"
},
"suggest": {
- "ext-pcov": "*",
- "ext-xdebug": "*"
+ "ext-pcov": "PHP extension that provides line coverage",
+ "ext-xdebug": "PHP extension that provides line coverage as well as branch and path coverage"
},
"type": "library",
"extra": {
@@ -299,7 +299,7 @@
],
"support": {
"issues": "https://github.com/sebastianbergmann/php-code-coverage/issues",
- "source": "https://github.com/sebastianbergmann/php-code-coverage/tree/10.0.1"
+ "source": "https://github.com/sebastianbergmann/php-code-coverage/tree/10.0.2"
},
"funding": [
{
@@ -307,7 +307,7 @@
"type": "github"
}
],
- "time": "2023-02-25T05:35:03+00:00"
+ "time": "2023-03-06T13:00:19+00:00"
},
{
"name": "phpunit/php-file-iterator",
@@ -852,16 +852,16 @@
},
{
"name": "sebastian/diff",
- "version": "5.0.0",
+ "version": "5.0.1",
"source": {
"type": "git",
"url": "https://github.com/sebastianbergmann/diff.git",
- "reference": "70dd1b20bc198da394ad542e988381b44e64e39f"
+ "reference": "aae9a0a43bff37bd5d8d0311426c87bf36153f02"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/sebastianbergmann/diff/zipball/70dd1b20bc198da394ad542e988381b44e64e39f",
- "reference": "70dd1b20bc198da394ad542e988381b44e64e39f",
+ "url": "https://api.github.com/repos/sebastianbergmann/diff/zipball/aae9a0a43bff37bd5d8d0311426c87bf36153f02",
+ "reference": "aae9a0a43bff37bd5d8d0311426c87bf36153f02",
"shasum": ""
},
"require": {
@@ -906,7 +906,8 @@
],
"support": {
"issues": "https://github.com/sebastianbergmann/diff/issues",
- "source": "https://github.com/sebastianbergmann/diff/tree/5.0.0"
+ "security": "https://github.com/sebastianbergmann/diff/security/policy",
+ "source": "https://github.com/sebastianbergmann/diff/tree/5.0.1"
},
"funding": [
{
@@ -914,7 +915,7 @@
"type": "github"
}
],
- "time": "2023-02-03T07:00:31+00:00"
+ "time": "2023-03-23T05:12:41+00:00"
},
{
"name": "sebastian/environment",