summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormax2020-11-21 15:32:32 +0100
committermax2020-12-07 16:45:34 +0100
commit98a2cb4d70d9397cab1f477bf7dbfa4fe05bc6f6 (patch)
tree0a1ae05670a42f38b5813f1bb5ad0aefdced3795
parent9029b8830ac560b8e6c9cf81890579399376099b (diff)
downloadaur-98a2cb4d70d9397cab1f477bf7dbfa4fe05bc6f6.tar.gz
Use gpg verification of phar archive
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD6
2 files changed, 7 insertions, 0 deletions
diff --git a/.gitignore b/.gitignore
index 1a97d8149c10..7880986aeb8c 100644
--- a/.gitignore
+++ b/.gitignore
@@ -8,4 +8,5 @@
# Downloaded sources
*.phar
+*.phar.asc
LICENSE*
diff --git a/PKGBUILD b/PKGBUILD
index 685ac2f7e0a6..cf8adf88e37b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -14,10 +14,16 @@ license=("BSD")
depends=("php>=7.0.0")
install="${_pkgname}.install"
source=("https://phar.phpunit.de/phpunit-${pkgver}.phar"
+ "https://phar.phpunit.de/phpunit-${pkgver}.phar.asc"
"LICENSE-${pkgver}::https://raw.githubusercontent.com/sebastianbergmann/phpunit/${pkgver}/LICENSE")
+# To add the key use gpg
+# gpg --keyserver pgp.uni-mainz.de --recv-keys 4AA394086372C20A
+validpgpkeys=('D8406D0D82947747293778314AA394086372C20A')
sha256sums=('aa56801ece16304dbd403fe7f82cd21e91ba01f45be6cdb3f4b3135489dcedfc'
+ 'SKIP'
'SKIP')
sha512sums=('SKIP'
+ 'SKIP'
'8e9e4a876a6b08ad44a60599ad23b3fad5b827925121f2daa427c4a682c6dd2b535151f3cf4f866231722bfb09866f1559fc3e82757a4e64405393ef7e0382cc')
package() {