summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordtbaumann2016-09-02 07:37:15 +0200
committerdtbaumann2016-09-02 07:37:15 +0200
commit705733080502a6cf825d0c8851ca6d666855c4b7 (patch)
treefd0576b7fbf96931c35c211aa9f5066f6df56811
parentfb91e3b63e1899c6d651e9bc77262b9a413cb54c (diff)
downloadaur-705733080502a6cf825d0c8851ca6d666855c4b7.tar.gz
update phreeqc.el
-rw-r--r--PKGBUILD4
-rw-r--r--phreeqc.el7
2 files changed, 8 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 27710c7f50d8..75e857a92a47 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=phreeqc
pkgver=3.3.7
_pkgsvn=11094
-pkgrel=1
+pkgrel=2
pkgdesc="A Computer Program for Speciation, Batch-Reaction, One-Dimensional Transport, and Inverse Geochemical Calculations"
arch=('i686' 'x86_64')
url="http://wwwbrr.cr.usgs.gov/projects/GWC_coupled/phreeqc/"
@@ -25,7 +25,7 @@ source=("ftp://brrftp.cr.usgs.gov/pub/charlton/phreeqc/phreeqc-$pkgver-$_pkgsvn.
"https://raw.githubusercontent.com/jaalto/project-emacs--folding-mode/master/folding.el")
md5sums=('5e245c7dd283b6eaf659927e65139a93'
'8facd6e784cd1985b2c57c092b753002'
- '98b0c08bd9bc4adb2ffe6706d4411b4e'
+ '0a5486d29b999e52dd8eb1bafd114699'
'd262512bd4a19a68805914d35f8f9019')
build() {
diff --git a/phreeqc.el b/phreeqc.el
index 6fdb9c6463df..5f80d3b26a28 100644
--- a/phreeqc.el
+++ b/phreeqc.el
@@ -453,7 +453,12 @@ with no args, if that value is non-nil."
(infile (buffer-name))
(outfile (concat (file-name-sans-extension infile) ".out"))
(database phreeqc-database))
-
+
+ ;; make sure that we start with a fresh output buffer to avoid problems
+ ;; with huge output buffers slowing down emacs
+ (if (buffer-live-p (get-buffer "*phreeqc*"))
+ (kill-buffer "*phreeqc*"))
+
(save-buffer)
;; check if a DATABASE keyword was given
(save-excursion