summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordtbaumann2017-02-04 19:54:50 +0100
committerdtbaumann2017-02-04 19:54:50 +0100
commit72b21f4dd795b5c41e7186333237f96dc34a42b7 (patch)
treeb378a7d2a9d04a31c127a128f3cb56828fefb488
parent4952dba82a62828fbea1891aeab75638fa2432b0 (diff)
downloadaur-72b21f4dd795b5c41e7186333237f96dc34a42b7.tar.gz
update phreeqc.el
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD4
-rw-r--r--phreeqc.el13
3 files changed, 18 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2813e4e2875b..0827cea3646b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Sun Jan 22 19:36:12 UTC 2017
+# Sat Feb 4 18:52:49 UTC 2017
pkgbase = phreeqc
pkgdesc = A Computer Program for Speciation, Batch-Reaction, One-Dimensional Transport, and Inverse Geochemical Calculations
pkgver = 3.3.10
- pkgrel = 1
+ pkgrel = 2
url = http://wwwbrr.cr.usgs.gov/projects/GWC_coupled/phreeqc/
install = install.sh
arch = i686
@@ -16,7 +16,7 @@ pkgbase = phreeqc
source = https://raw.githubusercontent.com/jaalto/project-emacs--folding-mode/master/folding.el
md5sums = c78db4331a9eaa469fcbee36e69a2101
md5sums = 8facd6e784cd1985b2c57c092b753002
- md5sums = 0a5486d29b999e52dd8eb1bafd114699
+ md5sums = 9418da9a10a0927516921c407288c039
md5sums = d262512bd4a19a68805914d35f8f9019
pkgname = phreeqc
diff --git a/PKGBUILD b/PKGBUILD
index 71c14dc3e26f..4579d171706d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=phreeqc
pkgver=3.3.10
_pkgsvn=12220
-pkgrel=1
+pkgrel=2
pkgdesc="A Computer Program for Speciation, Batch-Reaction, One-Dimensional Transport, and Inverse Geochemical Calculations"
arch=('i686' 'x86_64')
url="http://wwwbrr.cr.usgs.gov/projects/GWC_coupled/phreeqc/"
@@ -25,7 +25,7 @@ source=("ftp://brrftp.cr.usgs.gov/pub/charlton/phreeqc/phreeqc-$pkgver-$_pkgsvn.
"https://raw.githubusercontent.com/jaalto/project-emacs--folding-mode/master/folding.el")
md5sums=('c78db4331a9eaa469fcbee36e69a2101'
'8facd6e784cd1985b2c57c092b753002'
- '0a5486d29b999e52dd8eb1bafd114699'
+ '9418da9a10a0927516921c407288c039'
'd262512bd4a19a68805914d35f8f9019')
build() {
diff --git a/phreeqc.el b/phreeqc.el
index 5f80d3b26a28..0a7ec6986e73 100644
--- a/phreeqc.el
+++ b/phreeqc.el
@@ -52,6 +52,11 @@
:type 'string
:group 'phreeqc)
+(defcustom phreeqc-manual-fn "/usr/share/doc/phreeqc/Phreeqc_3_2013_manual.pdf"
+ "Name and path of the default thermodynamic database."
+ :type 'string
+ :group 'phreeqc)
+
(defcustom phreeqc-indent 4
"*This variable gives the indentation in Phreeqc-Mode."
:type 'integer
@@ -89,6 +94,8 @@
'("Visit Output" . phreeqc-visit-output))
(define-key menu-map [phreeqc-compile]
'("Run Phreeqc" . phreeqc-compile))
+ (define-key menu-map [phreeqc-manual]
+ '("Phreeqc manual" . phreeqc-visit-manual))
(setq phreeqc-mode-map map)))
(defvar phreeqc-output-mode-map nil
@@ -488,6 +495,12 @@ with no args, if that value is non-nil."
(concat (file-name-sans-extension buffer-file-name) ".out"))
(phreeqc-output-mode))
+(defun phreeqc-visit-manual ()
+ "Visit PhreeqC v3 manual"
+ (interactive)
+ (find-file-other-frame phreeqc-manual-fn))
+
+
(defun phreeqc-next-output-fold ()
"Visit output from Phreeqc-Simulation and move cursor to next fold."
(interactive)