summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristian Krause2015-06-25 13:01:58 +0200
committerChristian Krause2015-06-25 13:01:58 +0200
commit12a37a91837f376ea35dcb3bb8d6362c2996a32f (patch)
treeebf9426223155940ab8f8ac68b72b9093bdf105f
downloadaur-12a37a91837f376ea35dcb3bb8d6362c2996a32f.tar.gz
phylobayes-mpi-1.5a-1
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD32
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..290e3b0d0d01
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = phylobayes-mpi
+ pkgdesc = phylogenetic reconstruction using infinite mixtures
+ pkgver = 1.5a
+ pkgrel = 1
+ url = http://megasun.bch.umontreal.ca/People/lartillot/www/index.htm
+ arch = i686
+ arch = x86_64
+ license = custom
+ depends = openmpi
+ conflicts = phylobayes
+ source = http://megasun.bch.umontreal.ca/People/lartillot/www/pb_mpi1.5a.tar.gz
+ md5sums = bbb2b9193329a7b2253160b817f9fc87
+
+pkgname = phylobayes-mpi
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..13f432cf635a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Christian Krause ("wookietreiber") <kizkizzbangbang@googlemail.com>
+
+_pkgname=phylobayes
+pkgname=$_pkgname-mpi
+pkgver=1.5a
+pkgrel=1
+pkgdesc="phylogenetic reconstruction using infinite mixtures"
+arch=('i686' 'x86_64')
+url="http://megasun.bch.umontreal.ca/People/lartillot/www/index.htm"
+license=('custom')
+conflicts=(phylobayes)
+depends=('openmpi')
+source=("http://megasun.bch.umontreal.ca/People/lartillot/www/pb_mpi$pkgver.tar.gz")
+md5sums=('bbb2b9193329a7b2253160b817f9fc87')
+
+build() {
+ cd $srcdir/pb_mpi$pkgver/sources
+
+ make
+}
+
+package() {
+ cd $srcdir/pb_mpi$pkgver/data
+
+ mkdir -p $pkgdir/usr/bin $pkgdir/usr/share/licenses/$pkgname
+
+ find -mindepth 1 -maxdepth 1 -type f -printf '%P\n' | while read file ; do
+ cp $file $pkgdir/usr/bin
+ done
+
+ echo 'unknown' > $pkgdir/usr/share/licenses/$pkgname/LICENSE
+}