summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormalacology2021-05-27 11:46:23 +0800
committermalacology2021-05-27 11:46:23 +0800
commit45891c2ae9739daf85c9da5246e078a608751c23 (patch)
tree2d2a88d5093af87769e83592fa1ddb188a259445
downloadaur-45891c2ae9739daf85c9da5246e078a608751c23.tar.gz
newe
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD27
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fc3c97262f4f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = phylonet
+ pkgdesc = TA suite of software tools for reconstructing/analyzing phylogenetic networks in the presence of reticulate evolutionary events
+ pkgver = 3.8.2
+ pkgrel = 1
+ url = https://bioinfocs.rice.edu/PhyloNet
+ arch = x86_64
+ license = GPL2
+ depends = jre-openjdk-headless
+ depends = jre-openjdk
+ depends = jdk-openjdk
+ depends = openjdk-doc
+ depends = openjdk-src
+ source = https://bioinfocs.rice.edu/sites/g/files/bxs266/f/kcfinder/files/PhyloNet_3.8.2.jar
+ sha256sums = 0aa9c0e90c751ba14202e193f415d415fd9586a9a2b74c9fb22bbcaf306168d0
+
+pkgname = phylonet
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c144b7ad2aa7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Malacology <guoyizhang at malacology dot com>
+# Contributor: Malacology <guoyizhang at malacology dot com>
+
+pkgname=phylonet
+_installname=PhyloNet
+pkgver=3.8.2
+pkgrel=1
+depends=(
+ 'jre-openjdk-headless'
+ 'jre-openjdk'
+ 'jdk-openjdk'
+ 'openjdk-doc'
+ 'openjdk-src'
+)
+pkgdesc="TA suite of software tools for reconstructing/analyzing phylogenetic networks in the presence of reticulate evolutionary events"
+arch=('x86_64')
+url="https://bioinfocs.rice.edu/PhyloNet"
+license=('GPL2')
+source=("https://bioinfocs.rice.edu/sites/g/files/bxs266/f/kcfinder/files/PhyloNet_3.8.2.jar")
+sha256sums=('0aa9c0e90c751ba14202e193f415d415fd9586a9a2b74c9fb22bbcaf306168d0')
+
+package() {
+ install -dm755 "$pkgdir"/usr/{bin,share/phylonet}
+ install -Dm644 ${srcdir}/${_installname}_${pkgver}.jar ${pkgdir}/usr/share/phylonet/${_installname}.jar
+ ln -s /usr/share/phylonet/${_installname}.jar ${pkgdir}/usr/bin/${_installname}.jar
+}
+