summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristian Krause2015-06-13 11:57:09 +0200
committerChristian Krause2015-06-13 11:57:09 +0200
commit8c9de051609cde9ea4519900e55ecdbbf0113852 (patch)
treef3079d6acdc875b48026d8cc808a1287127cde95
downloadaur-8c9de051609cde9ea4519900e55ecdbbf0113852.tar.gz
Initial import
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD29
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d2044cca6eda
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = phyml-beagle
+ pkgdesc = Phylogenetic estimation using (Maximum) Likelihood
+ pkgver = 20141029
+ pkgrel = 1
+ url = https://github.com/stephaneguindon/phyml/
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ depends = beagle-lib
+ source = https://github.com/stephaneguindon/phyml-downloads/releases/download/development/phyml-20141029.tar.gz
+ md5sums = 7d144bb5634f003a916297acc0fb4867
+
+pkgname = phyml-beagle
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..46e2e04c3bc1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Christian Krause ("wookietreiber") <kizkizzbangbang@googlemail.com>
+
+pkgname=phyml-beagle
+pkgver=20141029
+pkgrel=1
+pkgdesc="Phylogenetic estimation using (Maximum) Likelihood"
+arch=('i686' 'x86_64')
+url="https://github.com/stephaneguindon/phyml/"
+license=('GPL2')
+depends=('beagle-lib')
+source=("https://github.com/stephaneguindon/phyml-downloads/releases/download/development/phyml-$pkgver.tar.gz")
+md5sums=('7d144bb5634f003a916297acc0fb4867')
+
+build() {
+ cd $srcdir/phyml-$pkgver
+
+ ./configure \
+ --prefix=/usr \
+ --disable-static \
+ --enable-beagle
+
+ make
+}
+
+package() {
+ cd $srcdir/phyml-$pkgver
+
+ make DESTDIR=$pkgdir install
+}