summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRhinoceros2015-06-09 08:34:39 +1000
committerRhinoceros2015-06-09 08:34:39 +1000
commitada306346713c0575e318c45f3140119d3de9f19 (patch)
treed0aa3845fe233b45866429580c6b2ca718155f40
downloadaur-ada306346713c0575e318c45f3140119d3de9f19.tar.gz
Initial commit of 20141029-1
* Modified version of phyml, with --enable-mpi, to use multiple processors * Clean up code
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD28
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cd769460c242
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = phyml-mpi
+ pkgdesc = Builds phylogenies from DNA or protein sequences using a maximum likelihood approach, using multiple proccessors
+ pkgver = 20141029
+ pkgrel = 1
+ url = https://github.com/stephaneguindon/phyml
+ arch = i686
+ arch = x86_64
+ license = GPLv2
+ depends = openmpi
+ source = https://github.com/stephaneguindon/phyml-downloads/releases/download/development/phyml-20141029.tar.gz
+ sha256sums = cb1d71107111de8509c4063d2bc1b290f5f2bcb23da136d829bc0450114f5576
+
+pkgname = phyml-mpi
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..191beee6fc47
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Rhinoceros <https://aur.archlinux.org/account/rhinoceros>
+# Contributor: Michael Schubert <mschu.dev at gmail>
+# Contributor: Mick Elliot <micke at sfu dot ca>
+
+pkgname=phyml-mpi
+pkgver=20141029
+pkgrel=1
+pkgdesc='Builds phylogenies from DNA or protein sequences using a maximum likelihood approach, using multiple proccessors'
+arch=('i686' 'x86_64')
+url='https://github.com/stephaneguindon/phyml'
+license=('GPLv2')
+source=("https://github.com/stephaneguindon/phyml-downloads/releases/download/development/phyml-$pkgver.tar.gz")
+sha256sums=('cb1d71107111de8509c4063d2bc1b290f5f2bcb23da136d829bc0450114f5576')
+depends=('openmpi')
+
+build() {
+ cd "${pkgname%-mpi}-$pkgver"
+ aclocal
+ autoreconf --force --install
+ automake --force --add-missing
+ ./configure --prefix=/usr --enable-mpi
+ make
+}
+
+package() {
+ cd "${pkgname%-mpi}-$pkgver"
+ make DESTDIR="$pkgdir" install
+}