summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWilson E. Alvarez2016-09-03 16:29:34 -0400
committerWilson E. Alvarez2016-09-03 16:29:34 -0400
commit58fafc1c0bfa34628cb46fde277645169fb430c7 (patch)
tree19c06ae66123a7e04852399cb0a3da99201a69a2
parentfdd45b357c86845ab01900ddda798ed06fd20f79 (diff)
downloadaur-58fafc1c0bfa34628cb46fde277645169fb430c7.tar.gz
Dependencies were corrected thanks to Geequlim
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD45
-rw-r--r--physicseditor.install9
3 files changed, 48 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index eb0ebc2ae191..57cd1439f103 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,22 @@
# Generated by mksrcinfo v8
-# Wed Jan 6 01:10:48 UTC 2016
+# Sat Sep 3 20:27:21 UTC 2016
pkgbase = physicseditor
pkgdesc = Physics editor for certain game engines such as Cocos2D-X, Corona SDK, etc.
pkgver = 1.5.2
- pkgrel = 1
- url = http://www.codeandweb.com
+ pkgrel = 2
+ url = http://www.codeandweb.com/physicseditor
install = physicseditor.install
arch = x86_64
license = custom:physicseditor
- depends = glib2
+ depends = shared-mime-info
depends = hicolor-icon-theme
depends = desktop-file-utils
- depends = shared-mime-info
+ depends = grantlee-qt5
+ depends = gcc-libs-multilib
+ depends = qt5-svg
+ depends = qt5-declarative
+ depends = qt5-imageformats
+ depends = qt5-quickcontrols
source = https://www.codeandweb.com/download/physicseditor/1.5.2/PhysicsEditor-1.5.2-ubuntu64.deb
md5sums = 05c3267ab57964659776ecc31557ee40
diff --git a/PKGBUILD b/PKGBUILD
index 33032dda3051..5556083b922c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,45 @@
# Maintainer: Wilson E. Alvarez <wilson.e.alvarez@hotmail.com>
+# Contributor: Etzos <supercodingmonkey @ gmail.com>
+# Contributer: Gordin <9ordin @t gmail dot com>
+# Contributor: Geequlim <geequlim@gmail.com>
pkgname=physicseditor
pkgver=1.5.2
-pkgrel=1
+pkgrel=2
pkgdesc="Physics editor for certain game engines such as Cocos2D-X, Corona SDK, etc."
arch=('x86_64')
-url="http://www.codeandweb.com"
-license=('custom:physicseditor')
-install='physicseditor.install'
-depends=('glib2' 'hicolor-icon-theme' 'desktop-file-utils' 'shared-mime-info')
-source=("https://www.codeandweb.com/download/physicseditor/${pkgver}/PhysicsEditor-${pkgver}-ubuntu64.deb")
+url="http://www.codeandweb.com/physicseditor"
+license=("custom:$pkgname")
+install="$pkgname.install"
+depends=('shared-mime-info' 'hicolor-icon-theme' 'desktop-file-utils' 'grantlee-qt5'
+ 'gcc-libs-multilib' 'qt5-svg' 'qt5-declarative' 'qt5-imageformats'
+ 'qt5-quickcontrols')
+source=("https://www.codeandweb.com/download/$pkgname/${pkgver}/PhysicsEditor-${pkgver}-ubuntu64.deb")
md5sums=('05c3267ab57964659776ecc31557ee40')
build() {
- ar -xv "PhysicsEditor-${pkgver}-ubuntu64.deb"
- tar -xvf data.tar.xz
+ ar -x "PhysicsEditor-${pkgver}-ubuntu64.deb"
}
package() {
- # Program
- mv ${srcdir}/usr ${pkgdir}
- # License
- install -Dm644 "${pkgdir}/usr/share/physicseditor/documents/LicenseAgreement.html" \
- "${pkgdir}/usr/share/licenses/${pkgname}/LicenseAgreement.html"
+ cd ${srcdir}/
+
+ # Extract to the $pkgdir.
+ tar xJf data.tar.xz -C "${pkgdir}/"
+
+ # Enter $pkgdir.
+ cd ${pkgdir}/usr/lib/$pkgname/
+
+ # Delete all the extra lib folders.
+ rm -rf generic/ grantlee/ iconengines/ imageformats/ platforminputcontexts/ platforms/ \
+ QtGraphicalEffects/ QtQml/ QtQuick/ QtQuick.2/ xcbglintegrations/
+
+ # Delete the useless lib files.
+ rm -rf libGrantlee* libicudata* libicui18n* libicuuc* libQt5*
+
+ # Get rid of the Qt configuration that messes up LD_LIBRARY_PATH.
+ rm -rf qt.conf
+
+ install -Dm644 "${pkgdir}/usr/share/$pkgname/documents/LicenseAgreement.txt" \
+ "${pkgdir}/usr/share/licenses/${pkgname}/LicenseAgreement.txt"
}
diff --git a/physicseditor.install b/physicseditor.install
index 21f9c6cadcbe..6be91e887fd4 100644
--- a/physicseditor.install
+++ b/physicseditor.install
@@ -2,8 +2,12 @@ post_install() {
update-mime-database usr/share/mime
update-desktop-database -q
gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
- echo "You must accept the terms of the EULA before using PhysicsEditor!"
- echo "Can be found in /usr/share/licenses/physicseditor/LicenseAgreement.html"
+ printf "%s\n" \
+ "You are required to accept the terms of the PhysicsEditor EULA before using the" \
+ "software. The software will prompt you to accept these terms on the first" \
+ "startup." \
+ "You can read the terms of the license without starting PhysicsEditor at:" \
+ " /usr/share/licenses/physicseditor/LicenseAgreement.txt"
}
post_upgrade() {
@@ -15,4 +19,3 @@ post_remove() {
update-desktop-database -q
gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
}
-