summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBert Münnich2015-06-25 11:04:32 +0200
committerBert Münnich2015-06-25 11:04:32 +0200
commit5dc1e0358ecf499c743784db1996bec730425564 (patch)
tree885a7cd96add3eeb65ec3c93d51a0da66c448a91
downloadaur-5dc1e0358ecf499c743784db1996bec730425564.tar.gz
Initial commit
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD23
2 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..47d780d0e363
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = physlock
+ pkgdesc = lightweight linux console locking tool
+ pkgver = 0.4.5
+ pkgrel = 1
+ url = https://github.com/muennich/physlock
+ arch = i686
+ arch = x86_64
+ license = GPL
+ source = https://github.com/muennich/physlock/archive/v0.4.5.tar.gz
+ md5sums = 5b39391638375c680599779aeee65569
+
+pkgname = physlock
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e70cc284d1e9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Bert Muennich <ber.t at posteo.de>
+
+pkgname=physlock
+pkgver=0.4.5
+pkgrel=1
+pkgdesc="lightweight linux console locking tool"
+arch=(i686 x86_64)
+license=('GPL')
+url="https://github.com/muennich/physlock"
+depends=()
+source=(https://github.com/muennich/physlock/archive/v${pkgver}.tar.gz)
+md5sums=('5b39391638375c680599779aeee65569')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make PREFIX="/usr"
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" PREFIX="/usr" install
+}
+