summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoonatan Saarhelo2015-12-19 01:34:30 +0200
committerJoonatan Saarhelo2015-12-19 01:34:30 +0200
commitdb5bda4ce3065d5e8a513ba894765ea0ac77dab9 (patch)
treefe39bbe5b8d9fdd23ac0ca66a885fd9e29e45550
downloadaur-db5bda4ce3065d5e8a513ba894765ea0ac77dab9.tar.gz
initial
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD44
2 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8ca78b70847a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by mksrcinfo v8
+# Fri Dec 18 23:34:09 UTC 2015
+pkgbase = phz-ric-git
+ pkgdesc = An image resizing and caching server.
+ pkgver = 0.1.r0.g62388c7
+ pkgrel = 1
+ arch = any
+ license = GPL
+ makedepends = go>=1.3.0
+ depends = imagemagick
+ provides = phz-ric
+ source = git+https://github.com/phzfi/RIC.git
+ md5sums = SKIP
+
+pkgname = phz-ric-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5e164d919d37
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Joonatan Saarhelo <joon.saar@gmail.com>
+pkgname=phz-ric-git
+pkgver=0.1.r0.g62388c7
+pkgrel=1
+pkgdesc="An image resizing and caching server."
+arch=('any')
+url=""
+license=('GPL')
+groups=()
+depends=('imagemagick')
+makedepends=('go>=1.3.0')
+optdepends=()
+provides=('phz-ric')
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("git+https://github.com/phzfi/RIC.git")
+noextract=()
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/RIC"
+ git describe --long --tags | sed -r 's/([^-]*-g)/r\1/;s/-/./g'
+}
+
+build() {
+ cd $srcdir
+
+ export GOPATH=$srcdir
+ mkdir -p $GOPATH/src/github.com/phzfi/
+ mv $srcdir/RIC $GOPATH/src/github.com/phzfi/
+
+ go get github.com/phzfi/RIC/server
+}
+
+package() {
+ cd $srcdir
+
+ mkdir -p $pkgdir/usr/bin
+ mv -T bin/server $pkgdir/usr/bin/phz-ric
+}