summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorpatlux2015-07-10 19:55:09 +0200
committerpatlux2015-07-10 19:55:09 +0200
commited21c995fb08b4a26052512086e720e7a9434f20 (patch)
tree814d1693e42ee0e2ad1dcc48f05568e98ebfee7b
downloadaur-ed21c995fb08b4a26052512086e720e7a9434f20.tar.gz
Initial import
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD39
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..87e1df1aa3ba
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = pi-blaster-git
+ pkgdesc = Daemon for Raspberry Pi which provides an interface to drive multiple PWM via the GPIO pins
+ pkgver = 20150610.r130.2cd6659
+ pkgrel = 1
+ url = https://github.com/sarfata/pi-blaster/
+ arch = any
+ license = MIT
+ makedepends = autoconf
+ makedepends = git
+ source = git+https://github.com/sarfata/pi-blaster
+ sha256sums = SKIP
+
+pkgname = pi-blaster-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..05939d17a1f1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Patrick Wozniak <hello@patwoz.de>
+
+pkgname=pi-blaster-git
+_gitname=${pkgname%-*}
+pkgver=20150610.r130.2cd6659
+pkgrel=1
+pkgdesc="Daemon for Raspberry Pi which provides an interface to drive multiple PWM via the GPIO pins"
+
+arch=('any')
+url="https://github.com/sarfata/pi-blaster/"
+license=('MIT')
+
+makedepends=('autoconf' 'git')
+source=("git+https://github.com/sarfata/${_gitname}")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$_gitname"
+ ( set -o pipefail
+ git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "%s.r%s.%s" "$(date +%Y%m%d)" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+prepare() {
+ cd "$_gitname"
+ ./autogen.sh
+}
+
+build() {
+ cd "$_gitname"
+ ./configure --sbindir=/usr/bin
+ make
+}
+
+package() {
+ cd "$_gitname"
+ make DESTDIR="$pkgdir/" install
+}