summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormax.bra2016-10-30 16:01:01 +0100
committermax.bra2016-10-30 16:01:01 +0100
commit7758f518584832a0c4e9b856ce3e4740eee2a160 (patch)
treecec52ebcfdf9d51eb0c7073e66a0e1001c53387e
parent7a563b8cadeb05824f7aa0e55ecc52f5d2b633f7 (diff)
downloadaur-7758f518584832a0c4e9b856ce3e4740eee2a160.tar.gz
v. 2.9.5
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD45
-rw-r--r--configuration8
-rw-r--r--dnsmasq.main (renamed from dnsmasq.complete)7
-rw-r--r--mimic_setupVars.conf.sh2
-rw-r--r--pi-hole-standalone.install4
6 files changed, 32 insertions, 48 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 765d03c64374..7add48389e4d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = pi-hole-standalone
pkgdesc = The Pi-hole is an advertising-aware DNS/Web server. Arch alteration for standalone PC.
- pkgver = 2.9.4
+ pkgver = 2.9.5
pkgrel = 1
url = https://github.com/pi-hole/pi-hole
install = pi-hole-standalone.install
@@ -11,24 +11,24 @@ pkgbase = pi-hole-standalone
conflicts = pi-hole-server
backup = etc/pihole/whitelist.txt
backup = etc/pihole/blacklist.txt
- source = https://github.com/pi-hole/pi-hole/archive/v2.9.4.tar.gz
+ source = https://github.com/pi-hole/pi-hole/archive/v2.9.5.tar.gz
source = configuration
- source = dnsmasq.complete
+ source = dnsmasq.main
source = dnsmasq.include
source = pi-hole-gravity.service
source = pi-hole-gravity.timer
source = whitelist.txt
source = blacklist.txt
source = mimic_setupVars.conf.sh
- md5sums = 07d21b50616cab39726262f86a98cd8b
- md5sums = 334a055a32b5479141baea8011a9f928
- md5sums = fa485f038d577c354068410ed1159d94
+ md5sums = b383a2741e556a3680b3ae312a18cfba
+ md5sums = bc28e67029222243ba2ca9b3a1855469
+ md5sums = 4bba639dcff6dd53c7d73e2fa1079f1f
md5sums = 1b2e808b699a6b58647641f12379f65d
md5sums = 047f13d4ac97877f724f87b002aaee63
md5sums = d42a864f88299998f8233c0bc0dd093d
md5sums = d41d8cd98f00b204e9800998ecf8427e
md5sums = d41d8cd98f00b204e9800998ecf8427e
- md5sums = f6e48b0ca309be5dbc38bfe5351890f9
+ md5sums = 10d149fd88ba428584333a151c164915
pkgname = pi-hole-standalone
diff --git a/PKGBUILD b/PKGBUILD
index f301632e6a8c..4f8a93563f62 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=pi-hole-standalone
_pkgname=pi-hole
-pkgver=2.9.4
+pkgver=2.9.5
pkgrel=1
pkgdesc='The Pi-hole is an advertising-aware DNS/Web server. Arch alteration for standalone PC.'
arch=('any')
@@ -15,7 +15,7 @@ backup=('etc/pihole/whitelist.txt' 'etc/pihole/blacklist.txt')
source=(https://github.com/$_pkgname/$_pkgname/archive/v$pkgver.tar.gz
configuration
- dnsmasq.complete
+ dnsmasq.main
dnsmasq.include
$_pkgname-gravity.service
$_pkgname-gravity.timer
@@ -23,31 +23,19 @@ source=(https://github.com/$_pkgname/$_pkgname/archive/v$pkgver.tar.gz
blacklist.txt
mimic_setupVars.conf.sh)
-md5sums=('07d21b50616cab39726262f86a98cd8b'
- '334a055a32b5479141baea8011a9f928'
- 'fa485f038d577c354068410ed1159d94'
+md5sums=('b383a2741e556a3680b3ae312a18cfba'
+ 'bc28e67029222243ba2ca9b3a1855469'
+ '4bba639dcff6dd53c7d73e2fa1079f1f'
'1b2e808b699a6b58647641f12379f65d'
'047f13d4ac97877f724f87b002aaee63'
'd42a864f88299998f8233c0bc0dd093d'
'd41d8cd98f00b204e9800998ecf8427e'
'd41d8cd98f00b204e9800998ecf8427e'
- 'f6e48b0ca309be5dbc38bfe5351890f9')
+ '10d149fd88ba428584333a151c164915')
prepare() {
_ssc="/tmp/sedcontrol"
- # change local ip to unusable 0.0.0.0 (ref. http://dlaa.me/blog/post/skyhole), and :: for ipv6
- sed -i 's|ipv4addr=\"\$piholeIP\"|ipv4addr=\"0.0.0.0\"|'"w $_ssc" "$srcdir"/$_pkgname-$pkgver/advanced/Scripts/blacklist.sh
- if [ -s $_ssc ] ; then rm $_ssc ; else echo " ==> Sed error: change local ip to unusable 0.0.0.0 (ref. http://dlaa.me/blog/post/skyhole), and :: for ipv6 1" && return 1 ; fi
- sed -i 's|ipv6addr=\"\$piholeIPv6\"|ipv6addr=\"::\"|'"w $_ssc" "$srcdir"/$_pkgname-$pkgver/advanced/Scripts/blacklist.sh
- if [ -s $_ssc ] ; then rm $_ssc ; else echo " ==> Sed error: change local ip to unusable 0.0.0.0 (ref. http://dlaa.me/blog/post/skyhole), and :: for ipv6 2" && return 1 ; fi
- sed -i 's|ipv4addr=\"\$piholeIP\"|ipv4addr=\"0.0.0.0\"|'"w $_ssc" "$srcdir"/$_pkgname-$pkgver/advanced/Scripts/whitelist.sh
- if [ -s $_ssc ] ; then rm $_ssc ; else echo " ==> Sed error: change local ip to unusable 0.0.0.0 (ref. http://dlaa.me/blog/post/skyhole), and :: for ipv6 3" && return 1 ; fi
- sed -i 's|ipv6addr=\"\$piholeIPv6\"|ipv6addr=\"::\"|'"w $_ssc" "$srcdir"/$_pkgname-$pkgver/advanced/Scripts/whitelist.sh
- if [ -s $_ssc ] ; then rm $_ssc ; else echo " ==> Sed error: change local ip to unusable 0.0.0.0 (ref. http://dlaa.me/blog/post/skyhole), and :: for ipv6 4" && return 1 ; fi
-
-# -----------------
-
# setting up and securing pihole wrapper script
sed -n "/debugFunc() {/w $_ssc" "$srcdir"/$_pkgname-$pkgver/pihole
if [ -s $_ssc ] ; then rm $_ssc ; else echo " ==> Sed error: setting up and securing pihole wrapper script 1" && return 1 ; fi
@@ -63,23 +51,23 @@ prepare() {
sed -n "/updatePiholeFunc() {/w $_ssc" "$srcdir"/$_pkgname-$pkgver/pihole
if [ -s $_ssc ] ; then rm $_ssc ; else echo " ==> Sed error: setting up and securing pihole wrapper script 4" && return 1 ; fi
- sed -i '/updatePiholeFunc() {/,+67d' "$srcdir"/$_pkgname-$pkgver/pihole
+ sed -i '/updatePiholeFunc() {/,+4d' "$srcdir"/$_pkgname-$pkgver/pihole
- sed -n "/setupLCDFunction() {/w $_ssc" "$srcdir"/$_pkgname-$pkgver/pihole
+ sed -n "/reconfigurePiholeFunc() {/w $_ssc" "$srcdir"/$_pkgname-$pkgver/pihole
if [ -s $_ssc ] ; then rm $_ssc ; else echo " ==> Sed error: setting up and securing pihole wrapper script 5" && return 1 ; fi
- sed -i '/setupLCDFunction() {/,+4d' "$srcdir"/$_pkgname-$pkgver/pihole
+ sed -i '/reconfigurePiholeFunc() {/,+4d' "$srcdir"/$_pkgname-$pkgver/pihole
- sed -n "/uninstallFunc() {/w $_ssc" "$srcdir"/$_pkgname-$pkgver/pihole
+ sed -n "/setupLCDFunction() {/w $_ssc" "$srcdir"/$_pkgname-$pkgver/pihole
if [ -s $_ssc ] ; then rm $_ssc ; else echo " ==> Sed error: setting up and securing pihole wrapper script 6" && return 1 ; fi
- sed -i '/uninstallFunc() {/,+4d' "$srcdir"/$_pkgname-$pkgver/pihole
+ sed -i '/setupLCDFunction() {/,+4d' "$srcdir"/$_pkgname-$pkgver/pihole
sed -n "/chronometerFunc() {/w $_ssc" "$srcdir"/$_pkgname-$pkgver/pihole
if [ -s $_ssc ] ; then rm $_ssc ; else echo " ==> Sed error: setting up and securing pihole wrapper script 7" && return 1 ; fi
sed -i '/chronometerFunc() {/,+4d' "$srcdir"/$_pkgname-$pkgver/pihole
- sed -n "/reconfigurePiholeFunc() {/w $_ssc" "$srcdir"/$_pkgname-$pkgver/pihole
+ sed -n "/uninstallFunc() {/w $_ssc" "$srcdir"/$_pkgname-$pkgver/pihole
if [ -s $_ssc ] ; then rm $_ssc ; else echo " ==> Sed error: setting up and securing pihole wrapper script 8" && return 1 ; fi
- sed -i '/reconfigurePiholeFunc() {/,+4d' "$srcdir"/$_pkgname-$pkgver/pihole
+ sed -i '/uninstallFunc() {/,+4d' "$srcdir"/$_pkgname-$pkgver/pihole
sed -n "/::: \-[d,f,u,s,c,v]/w $_ssc" "$srcdir"/$_pkgname-$pkgver/pihole
if [ -s $_ssc ] ; then rm $_ssc ; else echo " ==> Sed error: setting up and securing pihole wrapper script 9" && return 1 ; fi
@@ -105,8 +93,6 @@ prepare() {
sed -n "/#ensure \/etc\/dnsmasq\.d\//w $_ssc" "$srcdir"/$_pkgname-$pkgver/gravity.sh
if [ -s $_ssc ] ; then rm $_ssc ; else echo " ==> Sed error: arch useless" && return 1 ; fi
sed -i '/#ensure \/etc\/dnsmasq\.d\//,+5d' "$srcdir"/$_pkgname-$pkgver/gravity.sh
- # cosmetics
- sed -i '325 a echo " done!"' "$srcdir"/$_pkgname-$pkgver/gravity.sh
}
package() {
@@ -115,8 +101,7 @@ package() {
install -dm755 "$pkgdir"/opt/pihole
install -Dm755 ./$_pkgname-$pkgver/gravity.sh "$pkgdir"/opt/pihole/gravity.sh || return 1
- install -Dm755 ./$_pkgname-$pkgver/advanced/Scripts/blacklist.sh "$pkgdir"/opt/pihole/blacklist.sh || return 1
- install -Dm755 ./$_pkgname-$pkgver/advanced/Scripts/whitelist.sh "$pkgdir"/opt/pihole/whitelist.sh || return 1
+ install -Dm755 ./$_pkgname-$pkgver/advanced/Scripts/list.sh "$pkgdir"/opt/pihole/list.sh || return 1
install -Dm755 mimic_setupVars.conf.sh "$pkgdir"/opt/pihole/mimic_setupVars.conf.sh || return 1
@@ -130,7 +115,7 @@ package() {
install -Dm644 ./$_pkgname-$pkgver/adlists.default "$pkgdir"/etc/pihole/adlists.default || return 1
install -Dm644 whitelist.txt "$pkgdir"/etc/pihole/whitelist.txt || return 1
install -Dm644 blacklist.txt "$pkgdir"/etc/pihole/blacklist.txt || return 1
- install -Dm644 dnsmasq.complete "$pkgdir"/etc/pihole/configs/dnsmasq.complete || return 1
+ install -Dm644 dnsmasq.main "$pkgdir"/etc/pihole/configs/dnsmasq.main || return 1
install -Dm644 dnsmasq.include "$pkgdir"/etc/pihole/configs/dnsmasq.include || return 1
install -Dm644 configuration "$pkgdir"/usr/share/doc/pihole/configuration || return 1
}
diff --git a/configuration b/configuration
index f67bf41e98c8..29c72e0bc146 100644
--- a/configuration
+++ b/configuration
@@ -1,6 +1,6 @@
Pi-hole Archlinux configuration instructions
Standalone version
-rev. 0.3
+rev. 0.4
It is possible to add custom ad-list server in /etc/pihole/adlists.list
@@ -19,7 +19,7 @@ A) First install steps
2) copy pi-hole include config lines in right place
# mkdir /etc/dnsmasq.d
- # cp /etc/pihole/configs/dnsmasq.include /etc/dnsmasq.d/pihole.conf
+ # cp /etc/pihole/configs/dnsmasq.include /etc/dnsmasq.d/01-pihole.conf
3) edit your /etc/dnsmasq.conf to uncomment last line (including new pi-hole config lines)
@@ -32,7 +32,9 @@ A) First install steps
4) backup original dnsmasq config file and copy pi-hole one
# cp /etc/dnsmasq.conf /etc/dnsmasq.orig
- # cp /etc/pihole/configs/dnsmasq.complete /etc/dnsmasq.conf
+ # cp /etc/pihole/configs/dnsmasq.main /etc/dnsmasq.conf
+ # mkdir /etc/dnsmasq.d
+ # cp /etc/pihole/configs/dnsmasq.include /etc/dnsmasq.d/01-pihole.conf
*** end if
diff --git a/dnsmasq.complete b/dnsmasq.main
index e520fc63b25c..d5008b16affd 100644
--- a/dnsmasq.complete
+++ b/dnsmasq.main
@@ -1,7 +1,3 @@
-# If you want dnsmasq to read another file, as well as /etc/hosts, use
-# this.
-addn-hosts=/etc/pihole/gravity.list
-
# The following two options make you a better netizen, since they
# tell dnsmasq to filter out queries which the public DNS cannot
# answer, and which load the servers (especially the root servers)
@@ -31,9 +27,6 @@ server=8.8.4.4
# you use this.)
listen-address=127.0.0.1
-# Set the cachesize here.
-cache-size=10000
-
# Normally responses which come from /etc/hosts and the DHCP lease
# file have Time-To-Live set as zero, which conventionally means
# do not cache further. If you are happy to trade lower load on the
diff --git a/mimic_setupVars.conf.sh b/mimic_setupVars.conf.sh
index 6972eb18c189..4e1b27b07719 100644
--- a/mimic_setupVars.conf.sh
+++ b/mimic_setupVars.conf.sh
@@ -4,7 +4,7 @@ setupVars=/etc/pihole/setupVars.conf
getDNSs()
{
- dnsmasqdns=(`grep server= /etc/pihole/configs/dnsmasq.complete | awk -F "=" '{print $2}'`)
+ dnsmasqdns=(`grep server= /etc/pihole/configs/dnsmasq.main | awk -F "=" '{print $2}'`)
piholeDNS1=${dnsmasqdns[0]}
piholeDNS2=${dnsmasqdns[1]}
}
diff --git a/pi-hole-standalone.install b/pi-hole-standalone.install
index c434b47e962d..8a121903b719 100644
--- a/pi-hole-standalone.install
+++ b/pi-hole-standalone.install
@@ -1,5 +1,9 @@
post_install() {
echo -e "\e[1;33m==>\e[0m Please read configuration instructions at /usr/share/doc/pihole/configuration"
+ echo -e "\e[1;33m==>\e[0m \e[1;31mVer. 2.9.5-1\e[0m: dnsmasq conf file is changed"
+ echo -e "\e[1;33m==>\e[0m \e[1;31mAttention\e[0m: dnsmasq config files used are now two and both mandatory."
+ echo -e "\e[1;33m==>\e[0m Pay attention to the name of the destination dnsmasq include config file"
+ echo -e "\e[1;33m==>\e[0m Please follow configuration upgrade steps"
echo -e "\e[1;33m==>\e[0m Neutrino emissions detected..."
[ -e /proc/net/if_inet6 ] && touch /etc/pihole/.useIPv6 #this will be obsoleted soon
/opt/pihole/mimic_setupVars.conf.sh