aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThomas Jost2018-01-09 11:24:39 +0100
committerThomas Jost2018-01-09 11:24:39 +0100
commitb27ab2d9a75688aba5b4cdb1bad68e76b5d05d51 (patch)
tree0f25f1d4baaea2098cfeb8720df28c44f7e9fba6
downloadaur-b27ab2d9a75688aba5b4cdb1bad68e76b5d05d51.tar.gz
Initial commit
-rw-r--r--.SRCINFO30
-rw-r--r--PKGBUILD36
-rw-r--r--pia-bin.desktop10
-rwxr-xr-xpia-bin.sh3
4 files changed, 79 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..76671662df9a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,30 @@
+# Generated by mksrcinfo v8
+# Tue Jan 9 10:24:02 UTC 2018
+pkgbase = pia-bin
+ pkgdesc = A tool that aims to help data controllers build and demonstrate compliance to the GDPR. Developped by the French CNIL.
+ pkgver = 1.0.7
+ pkgrel = 1
+ url = https://www.cnil.fr/fr/node/23992
+ arch = x86_64
+ license = GPL
+ depends = alsa-lib
+ depends = gconf
+ depends = gtk2
+ depends = nss
+ depends = libxss
+ depends = libxtst
+ source = https://github.com/LINCnil/pia-app/releases/download/1.0.7/PIA-GNU_Linux-x64.zip
+ source = pia-bin.png::https://raw.githubusercontent.com/LINCnil/pia-app/master/icons/default/icon%403x.png
+ source = pia-bin.desktop
+ source = pia-bin.sh
+ md5sums = 031c13efe56ee432270459da4dadbd1c
+ md5sums = fb5d79b7c5adc7836a17657f06b8aadc
+ md5sums = d1476afe74a6a6c0b8270302cdb9752e
+ md5sums = c165f89dd2f9492157b53de094edc1d6
+ sha256sums = a3407d1fdb17f2dae6b8dceba76ba7b1aeb7d8877917b6c00dfd7473ee430c0f
+ sha256sums = 54dd3df8eb4ba01328d8c1fe4b28b4cae928c8cd2915571f65b9634da2cd5383
+ sha256sums = 13df9ed6626fe179ae34ee17b0039c696a4a579642e013d8b11389b140b27976
+ sha256sums = 3e07f80419a8dd3d49cf9587a6dc23bc0d1fff224a149e9c5f15cce8f063dca7
+
+pkgname = pia-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..469de3f4c986
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Thomas Jost <schnouki@schnouki.net>
+pkgname=pia-bin
+pkgver=1.0.7
+pkgrel=1
+pkgdesc="A tool that aims to help data controllers build and demonstrate compliance to the GDPR. Developped by the French CNIL."
+arch=('x86_64')
+url="https://www.cnil.fr/fr/node/23992"
+license=('GPL')
+depends=('alsa-lib' 'gconf' 'gtk2' 'nss' 'libxss' 'libxtst')
+source=("https://github.com/LINCnil/pia-app/releases/download/${pkgver}/PIA-GNU_Linux-x64.zip"
+ "pia-bin.png::https://raw.githubusercontent.com/LINCnil/pia-app/master/icons/default/icon%403x.png"
+ "pia-bin.desktop"
+ "pia-bin.sh")
+md5sums=('031c13efe56ee432270459da4dadbd1c'
+ 'fb5d79b7c5adc7836a17657f06b8aadc'
+ 'd1476afe74a6a6c0b8270302cdb9752e'
+ 'c165f89dd2f9492157b53de094edc1d6')
+sha256sums=('a3407d1fdb17f2dae6b8dceba76ba7b1aeb7d8877917b6c00dfd7473ee430c0f'
+ '54dd3df8eb4ba01328d8c1fe4b28b4cae928c8cd2915571f65b9634da2cd5383'
+ '13df9ed6626fe179ae34ee17b0039c696a4a579642e013d8b11389b140b27976'
+ '3e07f80419a8dd3d49cf9587a6dc23bc0d1fff224a149e9c5f15cce8f063dca7')
+
+prepare() {
+ cd "$srcdir/PIA-GNU_Linux-x64"
+ rm -f ".DS_Store"
+}
+
+package() {
+ cd "$srcdir"
+ mkdir -p "$pkgdir/opt"
+ cp -r "PIA-GNU_Linux-x64" "$pkgdir/opt/pia"
+
+ install -Dm644 pia-bin.desktop "$pkgdir/usr/share/applications/pia-bin.desktop"
+ install -Dm644 pia-bin.png "$pkgdir/usr/share/pixmaps/pia-bin.png"
+ install -Dm755 pia-bin.sh "$pkgdir/usr/bin/pia-bin"
+}
diff --git a/pia-bin.desktop b/pia-bin.desktop
new file mode 100644
index 000000000000..e885d868509e
--- /dev/null
+++ b/pia-bin.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Type=Application
+Name=PIA (bin)
+Comment=Privacy Impact Assessment
+Icon=pia-bin
+Exec=pia-bin
+NoDisplay=false
+Categories=Office;
+StartupNotify=false
+Terminal=false
diff --git a/pia-bin.sh b/pia-bin.sh
new file mode 100755
index 000000000000..354bb6440615
--- /dev/null
+++ b/pia-bin.sh
@@ -0,0 +1,3 @@
+#!/usr/bin/env bash
+
+exec /opt/pia/PIA "$@"