aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJulian Flake2020-05-02 17:40:08 +0200
committerJulian Flake2020-05-02 17:40:08 +0200
commitb7d6b34bc4b6d7ea9046ca71d058a371259643eb (patch)
tree61095884c7afa1d3facd29e7f8ec7df9df0bfb6a
parentc91e3cdd0e4ee1209488a7619fdbf71c90d1844a (diff)
downloadaur-b7d6b34bc4b6d7ea9046ca71d058a371259643eb.tar.gz
changed URL, added LICENSE file
-rw-r--r--.SRCINFO4
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD14
3 files changed, 12 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 332565c01c1e..306934abb44a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -2,7 +2,7 @@ pkgbase = pia-bin
pkgdesc = A tool that aims to help data controllers build and demonstrate compliance to the GDPR. Developped by the French CNIL.
pkgver = 2.2.1
pkgrel = 1
- url = https://www.cnil.fr/fr/node/23992
+ url = https://github.com/LINCnil/pia-app
arch = x86_64
license = GPL
depends = fuse
@@ -11,9 +11,11 @@ pkgbase = pia-bin
source = https://github.com/LINCnil/pia-app/releases/download/v2.2.1/PIA-2.2.1.AppImage
source = pia-bin.png::https://github.com/LINCnil/pia-app/raw/master/icons/128x128.png
source = pia-bin.desktop
+ source = https://raw.githubusercontent.com/LINCnil/pia-app/v2.2.1/LICENSE
sha256sums = e30404744759b82fba6b95ba9f36f4b81d3928961c179de14d52cd8749895592
sha256sums = 70b5b9d4f58be2c3601aa06a9793e4e57067a644cc5c4c54605b73c652031330
sha256sums = ddf3ff71ceb6be91af9b1856e593fa9bcba05d575beb20d1946d63dd7df51c9e
+ sha256sums = 7dcfd26f67041962a7e1554b5ef3398d4faac0d543c20d4ae27ddc4b6d41ec8a
pkgname = pia-bin
diff --git a/.gitignore b/.gitignore
index 8d9484b85b8f..daaeaa1a1926 100644
--- a/.gitignore
+++ b/.gitignore
@@ -3,3 +3,4 @@ PIA-*.AppImage
pia-bin.png
pkg/
src/
+LICENSE
diff --git a/PKGBUILD b/PKGBUILD
index ef235e132741..abeff3dedcca 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,23 +6,25 @@ pkgver=2.2.1
pkgrel=1
pkgdesc="A tool that aims to help data controllers build and demonstrate compliance to the GDPR. Developped by the French CNIL."
arch=('x86_64')
-url="https://www.cnil.fr/fr/node/23992"
+url="https://github.com/LINCnil/pia-app"
license=('GPL')
depends=('fuse' 'zlib')
options=('!strip')
source=("https://github.com/LINCnil/pia-app/releases/download/v${pkgver}/PIA-${pkgver}.AppImage"
"pia-bin.png::https://github.com/LINCnil/pia-app/raw/master/icons/128x128.png"
- "pia-bin.desktop")
-#md5sums=('7fd9f7253a6e8073653e6cf86ce45f70'
-# 'fb5d79b7c5adc7836a17657f06b8aadc'
-# '8178820ff951b19a7e9b6bb10a0f8062')
+ "pia-bin.desktop"
+ "https://raw.githubusercontent.com/LINCnil/pia-app/v${pkgver}/LICENSE"
+)
sha256sums=('e30404744759b82fba6b95ba9f36f4b81d3928961c179de14d52cd8749895592'
'70b5b9d4f58be2c3601aa06a9793e4e57067a644cc5c4c54605b73c652031330'
- 'ddf3ff71ceb6be91af9b1856e593fa9bcba05d575beb20d1946d63dd7df51c9e')
+ 'ddf3ff71ceb6be91af9b1856e593fa9bcba05d575beb20d1946d63dd7df51c9e'
+ '7dcfd26f67041962a7e1554b5ef3398d4faac0d543c20d4ae27ddc4b6d41ec8a'
+ )
package() {
cd "$srcdir"
install -Dm644 pia-bin.desktop "$pkgdir/usr/share/applications/pia-bin.desktop"
install -Dm644 pia-bin.png "$pkgdir/usr/share/pixmaps/pia-bin.png"
install -Dm755 "PIA-${pkgver}.AppImage" "$pkgdir/usr/bin/PIA"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/pia-bin/LICENSE"
}