summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorasukaminato2023-04-01 19:31:46 +0900
committerasukaminato2023-04-01 19:31:46 +0900
commit8e30a619822263697f69d5ea1212d7fba7bee925 (patch)
treebc60c74504b26c8aeb0456d3acbd57d4b820ba8b
downloadaur-8e30a619822263697f69d5ea1212d7fba7bee925.tar.gz
init
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD60
-rw-r--r--piano-rs.sh3
4 files changed, 85 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4d17613afddd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = piano-rs-git
+ pkgdesc = A multiplayer piano using UDP sockets that can be played using computer keyboard, in the terminal
+ pkgver = v0.1.0.r99.ge7d1163
+ pkgrel = 1
+ url = https://github.com/ritiek/piano-rs/
+ arch = any
+ license = MIT
+ makedepends = git
+ makedepends = cargo
+ depends = glibc
+ depends = gcc-libs
+ depends = alsa-lib
+ source = git+https://github.com/ritiek/piano-rs.git
+ source = piano-rs.sh
+ sha256sums = SKIP
+ sha256sums = 99d9bea2b2bc084e48a703fc1dad2066e9b419b7869ea69f43d673f3cfae9b45
+
+pkgname = piano-rs-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..0fca90ce8c87
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg
+src
+*.zst
+piano-rs
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a343cc5d05c0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,60 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Maintainer: Your Name <youremail@domain.com>
+pkgname=piano-rs-git
+pkgver=v0.1.0.r99.ge7d1163
+pkgrel=1
+epoch=
+pkgdesc="A multiplayer piano using UDP sockets that can be played using computer keyboard, in the terminal"
+arch=('any')
+url="https://github.com/ritiek/piano-rs/"
+license=('MIT')
+groups=()
+depends=(glibc gcc-libs alsa-lib)
+makedepends=(git cargo)
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("git+https://github.com/ritiek/piano-rs.git"
+piano-rs.sh)
+noextract=()
+sha256sums=('SKIP'
+ '99d9bea2b2bc084e48a703fc1dad2066e9b419b7869ea69f43d673f3cfae9b45')
+validpgpkeys=()
+pkgver() {
+ cd "piano-rs"
+ git describe --long --tags --abbrev=7 | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ pushd piano-rs
+ cargo fetch --locked --target "$CARCH-unknown-linux-gnu"
+}
+
+build() {
+ pushd piano-rs
+ export RUSTUP_TOOLCHAIN=stable
+ export CARGO_TARGET_DIR=target
+ cargo build --release --all-features
+}
+check() {
+ pushd piano-rs
+ export RUSTUP_TOOLCHAIN=stable
+ cargo test --frozen --all-features
+}
+package() {
+ install -Dm755 piano-rs.sh $pkgdir/usr/bin/piano-rs
+ pushd piano-rs
+ install -Dm0755 -t "$pkgdir/opt/$pkgname/" "target/release/piano-rs"
+ install -Dm644 LICENSE* -t "$pkgdir/usr/share/licenses/$pkgname"
+ cp -av assets $pkgdir/opt/$pkgname/
+}
diff --git a/piano-rs.sh b/piano-rs.sh
new file mode 100644
index 000000000000..f99d212d3c3a
--- /dev/null
+++ b/piano-rs.sh
@@ -0,0 +1,3 @@
+#!/bin/sh
+pushd /opt/piano-rs-git/
+./piano-rs