summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsaikia812016-03-26 22:38:36 +0100
committersaikia812016-03-26 22:38:36 +0100
commit4b8dba8c4328d84a618c3a4dc8a0f313468ecc65 (patch)
tree6265940ec4c0f42eab656e88c490a0a94b137d23
downloadaur-4b8dba8c4328d84a618c3a4dc8a0f313468ecc65.tar.gz
initial commit
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD75
2 files changed, 97 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2d1173c405a1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = pianoteq-stage
+ pkgdesc = Virtual piano instrument using physical modelling synthesis. Both standalone and plugin versions.
+ pkgver = 5.5.1
+ pkgrel = 1
+ url = https://www.pianoteq.com/pianoteq5
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ makedepends = gendesk
+ makedepends = p7zip
+ depends = alsa-lib
+ depends = freetype2
+ depends = libxext
+ provides = pianoteq
+ conflicts = pianoteq
+ conflicts = pianoteq-stage-bin,
+ conflicts = pianoteq-standard-trial-bin
+ source = https://www.pianoteq.com/images/logo/pianoteq_icon_128.png
+ sha256sums = 94ee64cf6688a49d74f0bf70d811e7466abac103feeab17496a89f828afcc6d3
+
+pkgname = pianoteq-stage
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..79fcb82bfe4b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,75 @@
+# Maintainer: Saiki81 <saikia81 at hotmail dot com>
+# adapted from package: pianoteq-stage-trial-bin
+# package Creator: CrocoDuck <crocoduck dot oducks at gmail dot com>
+
+
+pkgname=pianoteq-stage
+pkgver=5.5.1
+pkgrel=1
+pkgdesc="Virtual piano instrument using physical modelling synthesis. Both standalone and plugin versions."
+arch=('i686' 'x86_64')
+url="https://www.pianoteq.com/pianoteq5"
+license=('LGPL')
+depends=('alsa-lib' 'freetype2' 'libxext')
+makedepends=('gendesk' 'p7zip')
+provides=("${pkgname%-*}")
+conflicts=("${pkgname%-*}" "pianoteq-stage-bin", "pianoteq-standard-trial-bin")
+source=('https://www.pianoteq.com/images/logo/pianoteq_icon_128.png')
+sha256sums=('94ee64cf6688a49d74f0bf70d811e7466abac103feeab17496a89f828afcc6d3')
+
+# Define the target archive filename:
+_downfname=pianoteq_stage_linux_v${pkgver//./}.7z
+# Define its checksum:
+_downsha256sum=c6304a2c6c6c422df5216976715b0bec2e77ad257adfad697d3902401d1bdda0
+
+prepare(){
+ # the source package must be downloaded manually
+ # this can be done by going to the link here:
+ # https://www.pianoteq.com/download?file=pianoteq_stage_linux_v551.7z
+ # the checksum will still be validated
+ if [ ! -f ../pianoteq_stage_linux_v551.7z ]
+ then
+ echo "File not found!"
+ echo -e "For this package a mannual download of the pianoteq software is needed: 'https://www.pianoteq.com/download?file=pianoteq_stage_linux_v551.7z'\nThe archive should be in the same dir as the PKGBUILD!"
+ exit;
+ fi
+ # move the dependency to ./src/
+ mv ../$_downfname ./
+ # Check integrity:
+ echo $_downsha256sum $_downfname|sha256sum -c || { echo 'Checksum failed!'; exit 1; }
+ # Extract:
+ 7z x $_downfname
+ # Generate Desktop Entry:
+ gendesk -f -n --pkgname "$pkgname" --pkgdesc "$pkgdesc" --name='Pianoteq 5' --exec='Pianoteq\ 5' --categories 'Audio;Sequencer;Midi;AudioVideoEditing;Music;AudioVideo;'
+}
+
+package(){
+ _pianoteq_type="Pianoteq 5 STAGE"
+ # Define architecture specific file directory:
+ if [[ "$CARCH" == i686 ]]; then
+ archdir=i386
+ else
+ archdir=amd64
+ fi
+ # Install program files:
+ install -Dm 755 "$srcdir/$_pianoteq_type/$archdir/$_pianoteq_type" "$pkgdir/usr/bin/Pianoteq 5"
+ install -Dm 755 "$srcdir/$_pianoteq_type/$archdir/$_pianoteq_type.so" "$pkgdir/usr/lib/vst/Pianoteq 5.so"
+ cd "$srcdir/$_pianoteq_type/$archdir/$_pianoteq_type.lv2"
+ for i in *; do
+ install -D "$i" "$pkgdir/usr/lib/lv2/Pianoteq 5.lv2/$i"
+ done
+ cd $srcdir
+ # Install desktop launcher:
+ install -Dm 644 "$srcdir/pianoteq_icon_128.png" "$pkgdir/usr/share/pixmaps/$pkgname.png"
+ install -Dm 644 "$srcdir/$pkgname.desktop" "$pkgdir/usr/share/applications/${pkgname%-*}.desktop"
+ # Install the license:
+ install -d "$pkgdir/usr/share/licenses/$pkgname"
+ ls -a
+ install -m 644 "$_pianoteq_type"/*Licence* "$pkgdir/usr/share/licenses/$pkgname/"
+ # Install the Documentation:
+ install -D "$_pianoteq_type/README_LINUX.txt" "$pkgdir/usr/share/doc/${pkgname%-*}/README_LINUX.txt"
+ cd "$srcdir/$_pianoteq_type/Documentation"
+ for i in *; do
+ install -D "$i" "$pkgdir/usr/share/doc/${pkgname%-*}/$i"
+ done
+}