summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsaikia812017-10-30 16:29:49 +0100
committersaikia812017-10-30 16:29:49 +0100
commit8dd7f122a34e42a5f266a58bc07a1dd8c5fdc088 (patch)
tree6de177abd515251dd505e4dcaabda3483edf3db0
downloadaur-8dd7f122a34e42a5f266a58bc07a1dd8c5fdc088.tar.gz
init new pianoteq-stage repo to sustain pianoteq 5 support
-rwxr-xr-x.SRCINFO23
-rwxr-xr-xPKGBUILD82
2 files changed, 105 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100755
index 000000000000..a10904631e6d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = pianoteq-stage5
+ pkgdesc = Virtual piano instrument using physical modelling synthesis. Both standalone and plugin versions.
+ pkgver = 5.8.1
+ pkgrel = 1
+ url = https://www.pianoteq.com/pianoteq5
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ makedepends = gendesk
+ makedepends = wget
+ makedepends = p7zip
+ depends = alsa-lib
+ depends = freetype2
+ depends = libxext
+ provides = pianoteq
+ conflicts = pianoteq
+ conflicts = pianoteq-stage-bin,
+ conflicts = pianoteq-standard-trial-bin
+ source = https://www.pianoteq.com/images/logo/pianoteq_icon_128.png
+ sha256sums = 94ee64cf6688a49d74f0bf70d811e7466abac103feeab17496a89f828afcc6d3
+
+pkgname = pianoteq-stage
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..2ef658af4da3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,82 @@
+# Maintainer: Saiki81 <saikia81 at hotmail dot com>
+# adapted from package: pianoteq-stage-trial-bin
+# adapted from pkgbuild creator: CrocoDuck <crocoduck dot oducks at gmail dot com>
+
+
+pkgname=pianoteq-stage5
+pkgver=5.8.1
+pkgrel=1
+pkgdesc="Virtual piano instrument using physical modelling synthesis. Both standalone and plugin versions."
+arch=('i686' 'x86_64')
+url="https://www.pianoteq.com/pianoteq5"
+license=('LGPL')
+depends=('alsa-lib' 'freetype2' 'libxext')
+makedepends=('gendesk' 'wget' 'p7zip')
+optdepends=()
+provides=("${pkgname%-*}")
+conflicts=("${pkgname%-*}" "pianoteq-stage-bin", "pianoteq-standard-trial-bin")
+source=('https://www.pianoteq.com/images/logo/pianoteq_icon_128.png')
+sha256sums=('94ee64cf6688a49d74f0bf70d811e7466abac103feeab17496a89f828afcc6d3')
+
+# Define the target archive filename:
+_pianoteqfilename=pianoteq_stage_linux_v${pkgver//./}.7z
+# Define its checksum:
+_pianoteqsha256sum=ae0100a22432e73c2a7df8890b89239f04d3adc5a6d97440af9517e8e75187af
+
+prepare(){
+ # the source package must be downloaded manually
+ # this can be done by going to the link here:
+ # https://www.pianoteq.com/download?file=pianoteq_stage_linux_v581.7z
+ # the checksum will still be validated
+ if [ ! -f "../$_pianoteqfilename" ]
+ then
+ echo "File not found!"
+ echo "Pianoteq installation binary file is not found!"
+ echo -e "For this package a manual download of the Pianoteq installation binary is needed."
+ echo -e "Please go to 'https://www.pianoteq.com/download?file=${_pianoteqfilename}'"
+ echo -e "and log in with your user account."
+ echo -e "The archive should be in the same directory as the PKGBUILD!"
+ exit;
+ exit;
+ fi
+ # move the dependency to ./src/
+ mv ../$_pianoteqfilename ./
+ # Check integrity:
+ echo "$_pianoteqsha256sum $_pianoteqfilename" | sha256sum -c || { echo 'Checksum failed!'; exit 1; }
+ # Extract:
+ 7z x $_pianoteqfilename
+ # Generate Desktop Entry:
+ gendesk -f -n --pkgname "$pkgname" --pkgdesc "$pkgdesc" --name='pianoteq 5' --exec='pianoteq\ 5' --categories 'Audio;Sequencer;Midi;AudioVideoEditing;Music;AudioVideo;'
+ echo "Note: Try running pianoteq from a shell, if problems occur!"
+}
+
+package(){
+ _pianoteq_type="Pianoteq 5 STAGE"
+ # Define architecture specific file directory:
+ if [[ "$CARCH" == i686 ]]; then
+ archdir=i386
+ else
+ archdir=amd64
+ fi
+ # Install program files:
+ install -Dm 755 "$srcdir/$_pianoteq_type/$archdir/$_pianoteq_type" "$pkgdir/usr/bin/pianoteq 5"
+ install -Dm 755 "$srcdir/$_pianoteq_type/$archdir/$_pianoteq_type.so" "$pkgdir/usr/lib/vst/pianoteq 5.so"
+ cd "$srcdir/$_pianoteq_type/$archdir/$_pianoteq_type.lv2"
+ for i in *; do
+ install -D "$i" "$pkgdir/usr/lib/lv2/Pianoteq 5.lv2/$i"
+ done
+ cd $srcdir
+ # Install desktop launcher:
+ install -Dm 644 "$srcdir/pianoteq_icon_128.png" "$pkgdir/usr/share/pixmaps/$pkgname.png"
+ install -Dm 644 "$srcdir/$pkgname.desktop" "$pkgdir/usr/share/applications/${pkgname%-*}.desktop"
+ # Install the license:
+ install -d "$pkgdir/usr/share/licenses/$pkgname"
+ ls -a
+ install -m 644 "$_pianoteq_type"/*Licence* "$pkgdir/usr/share/licenses/$pkgname/"
+ # Install the Documentation:
+ install -D "$_pianoteq_type/README_LINUX.txt" "$pkgdir/usr/share/doc/${pkgname%-*}/README_LINUX.txt"
+ cd "$srcdir/$_pianoteq_type/Documentation"
+ for i in *; do
+ install -D "$i" "$pkgdir/usr/share/doc/${pkgname%-*}/$i"
+ done
+}