summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Arndt2021-03-30 15:17:06 +0200
committerChristopher Arndt2021-03-30 15:17:06 +0200
commita62554953e9622f14a7c07a49ca0d15c7f24ec98 (patch)
tree37a46f48d986604cdddca2186d058a949d297c5f
parent5270af044e1ba251b65918bb1e70e4eab0865a40 (diff)
downloadaur-a62554953e9622f14a7c07a49ca0d15c7f24ec98.tar.gz
New upstream version
* Distribution archive must now be downloaded manually and placed in in same directory as PKGBUILD, since upstream changed the download page flow, so it is not (easily) automatable any more.
-rw-r--r--.SRCINFO6
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD45
3 files changed, 15 insertions, 37 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 72ae8a0e2a1d..b4b34a3e3749 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = pianoteq-standard-trial-bin
pkgdesc = Physical modelling piano instrument as a standalone program and VST2 and LV2 plugins. STANDARD trial version
- pkgver = 7.1.0
+ pkgver = 7.2.0
pkgrel = 1
url = https://www.pianoteq.com/home
arch = x86_64
@@ -11,15 +11,15 @@ pkgbase = pianoteq-standard-trial-bin
groups = vst-plugins
license = custom
makedepends = gendesk
- makedepends = wget
- makedepends = p7zip
depends = alsa-lib
depends = libx11
optdepends = jack: JACK support for stand-alone application
provides = pianoteq-standard-trial
conflicts = pianoteq-standard-trial
conflicts = pianoteq-standard-bin
+ source = file://pianoteq_linux_trial_v720.7z
source = https://www.pianoteq.com/images/logo/pianoteq_icon_128.png
+ sha256sums = 97caf045c5ecb66acb6cf8fc2935e37f4e469cf9274814c7f636bd9e80ece15c
sha256sums = 94ee64cf6688a49d74f0bf70d811e7466abac103feeab17496a89f828afcc6d3
pkgname = pianoteq-standard-trial-bin
diff --git a/.gitignore b/.gitignore
index 105ec95c53a7..e2bf4a7b41aa 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,5 +1,6 @@
pkg/
src/
+pianoteq_linux_trial_v*.7z
pianoteq-standard-trial-bin-*.pkg.tar.xz
pianoteq-standard-trial-bin-*.pkg.tar.zst
pianoteq_icon_128.png
diff --git a/PKGBUILD b/PKGBUILD
index 477d6cb32cb9..f0e44c972707 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: Simon Thorpe <simon@hivetechnology.com.au>
pkgname=pianoteq-standard-trial-bin
-pkgver=7.1.0
+pkgver=7.2.0
pkgrel=1
pkgdesc="Physical modelling piano instrument as a standalone program and VST2 and LV2 plugins. STANDARD trial version"
arch=('x86_64' 'armv7h' 'aarch64')
@@ -11,42 +11,19 @@ url="https://www.pianoteq.com/home"
license=('custom')
groups=('lv2-plugins' 'pro-audio' 'vst-plugins')
depends=('alsa-lib' 'libx11')
-makedepends=('gendesk' 'wget' 'p7zip')
+makedepends=('gendesk')
optdepends=('jack: JACK support for stand-alone application')
provides=("${pkgname%-*}")
conflicts=("${pkgname%-*}" 'pianoteq-standard-bin')
-source=('https://www.pianoteq.com/images/logo/pianoteq_icon_128.png')
-sha256sums=('94ee64cf6688a49d74f0bf70d811e7466abac103feeab17496a89f828afcc6d3')
-
-# Define the target archive filename:
-_downfname="pianoteq_linux_trial_v${pkgver//./}.7z"
-# Define its checksum:
-_downsha256sum='858ab31b86627b5c8dbb8850825c8bd71ce666124d58f7760ebebd67b7114627'
+source=("file://pianoteq_linux_trial_v${pkgver//./}.7z"
+ 'https://www.pianoteq.com/images/logo/pianoteq_icon_128.png')
+sha256sums=('97caf045c5ecb66acb6cf8fc2935e37f4e469cf9274814c7f636bd9e80ece15c'
+ '94ee64cf6688a49d74f0bf70d811e7466abac103feeab17496a89f828afcc6d3')
prepare() {
- # Download archive, if neccessary
- if [[ ! -e "${srcdir}/${_downfname}" ]]; then
- # The archive download link needs to be retrieved. Retrieve download page source:
- wget -q -O downpage.html https://www.pianoteq.com/try?file="$_downfname"
-
- # Now, isolate the final string of the download link from the source:
- downstr=$(cat downpage.html | grep "<form action" | grep style | grep -o -P '(?<=action=").*(?=" method)')
-
- # All ingredients are ready! Finalize the download url and download:
- downurl="https://www.pianoteq.com/"$downstr""
- wget --content-disposition -O "${srcdir}/${_downfname}" "$downurl"
- fi
-
- # Check integrity:
- echo $_downsha256sum "${srcdir}/${_downfname}" | \
- sha256sum -c || { echo 'Checksum failed!'; exit 1; }
-
- # Extract:
- 7z x -y "${srcdir}/${_downfname}"
-
# Generate Desktop Entry:
gendesk -f -n \
- --pkgname "$pkgname" \
+ --pkgname "${pkgname%-*}" \
--pkgdesc "$pkgdesc" \
--name='Pianoteq 7' \
--exec="'Pianoteq 7'" \
@@ -76,8 +53,8 @@ package() {
# Install desktop launcher:
install -Dm 644 "$srcdir/pianoteq_icon_128.png" \
- "$pkgdir/usr/share/pixmaps/$pkgname.png"
- install -Dm 644 "$srcdir/$pkgname.desktop" \
+ "$pkgdir/usr/share/pixmaps/${pkgname%-*}.png"
+ install -Dm 644 "$srcdir/${pkgname%-*}.desktop" \
"$pkgdir/usr/share/applications/${pkgname%-*}.desktop"
# Install the license:
@@ -87,9 +64,9 @@ package() {
# Install the Documentation:
install -D "Pianoteq 7/README_LINUX.txt" \
- "$pkgdir/usr/share/doc/${pkgname%-*}/README_LINUX.txt"
+ "$pkgdir/usr/share/doc/${pkgname}/README_LINUX.txt"
cd "$srcdir/Pianoteq 7/Documentation"
for i in *; do
- install -D "$i" "$pkgdir/usr/share/doc/${pkgname%-*}/$i"
+ install -D "$i" "$pkgdir/usr/share/doc/${pkgname}/$i"
done
}