summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Severance2015-09-09 01:49:17 -0400
committerChris Severance2015-09-09 01:49:17 -0400
commitaef70dd1ecbd36734b9c1f09ecd95e164e8a4711 (patch)
tree7ba6eb86f2038823726053a0c195595a91bdfbb1
downloadaur-aef70dd1ecbd36734b9c1f09ecd95e164e8a4711.tar.gz
Initial Import
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD44
2 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..64725b8cdca6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = pico
+ pkgdesc = the real pico text editor from the Alpine Messaging System
+ pkgver = 2.00
+ pkgrel = 1
+ url = http://www.washington.edu/alpine/
+ arch = i686
+ arch = x86_64
+ license = apache
+ makedepends = gcc
+ depends = ncurses
+ source = ftp://ftp.cac.washington.edu/alpine/alpine-2.00.tar.bz2
+ sha256sums = c85db8405af90375ba2440c85b7952d80996154e9916b83acca558dc82e0a2a6
+
+pkgname = pico
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0f8b9cb6e29b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Chris Severance aur.severach aATt spamgourmet dott com
+
+set -u
+pkgname='pico'
+pkgver='2.00'
+pkgrel='1'
+pkgdesc='the real pico text editor from the Alpine Messaging System'
+license=('apache')
+depends=('ncurses')
+makedepends=('gcc')
+arch=('i686' 'x86_64')
+url='http://www.washington.edu/alpine/'
+source=("ftp://ftp.cac.washington.edu/alpine/alpine-${pkgver}.tar.bz2")
+sha256sums=('c85db8405af90375ba2440c85b7952d80996154e9916b83acca558dc82e0a2a6')
+
+prepare() {
+ set -u
+ cd "${srcdir}/alpine-${pkgver}"
+ # Disabling pam gets the Alpine make farther but then it crashes on a TCP error
+ sed -i -e 's:pam_start:pomme_start:g' 'configure'
+ ./configure --prefix='/usr' --without-ldap --without-ssl --without-krb5 --target 'slx'
+ set +u
+}
+
+build() {
+ set -u
+ cd "${srcdir}/alpine-${pkgver}"
+ make -s c-client
+ make -s c-client.d
+ make -s -j "$(nproc)" -C 'pith'
+ make -s -j "$(nproc)" -C 'pico'
+ # making Alpine crashes on pam errors
+ set +u
+}
+
+package() {
+ set -u
+ cd "${srcdir}/alpine-${pkgver}"
+ make DESTDIR="${pkgdir}" install -C 'pico'
+ rm -f "${pkgdir}/usr/bin"/{pilot,alpine,rpdump,rpload}
+ install -Dpm644 'doc/pico.1' -t "${pkgdir}/usr/share/man/man1/"
+ set +u
+}
+set +u