summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjzbor2022-01-27 19:11:22 +0100
committerjzbor2022-01-27 19:11:22 +0100
commit605c619e6baebf85c3f77167d6ee420ab1a68829 (patch)
tree0e996044f78fe211862075d4638628a75f4b6e68
parent391873ba9823403966c493b8e98bd68654810f9d (diff)
downloadaur-605c619e6baebf85c3f77167d6ee420ab1a68829.tar.gz
Adjusting PKGBUILD for animation forks
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD17
2 files changed, 18 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ac59014ed0bf..3d90b5d7e05d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
-pkgbase = picom-git
- pkgdesc = X compositor (fork of compton) (git-version)
- pkgver = 1430_8.rc2.21.gfd6ff82_2020.06.06
+pkgbase = picom-animations-git
+ pkgdesc = X compositor (fork of compton) (git-version; animation fork)
+ pkgver = 1666_Next.104.g6a50198_2021.09.19
pkgrel = 1
- url = https://github.com/yshui/picom
+ url = https://github.com/dccsillag/picom
arch = i686
arch = x86_64
license = MIT
@@ -36,8 +36,7 @@ pkgbase = picom-git
conflicts = compton-git
conflicts = picom
replaces = compton-git
- source = git+https://github.com/yshui/picom.git#branch=next
- md5sums = SKIP
-
-pkgname = picom-git
+ source = git+https://github.com/dccsillag/picom.git#branch=implement-window-animations
+ sha256sums = SKIP
+pkgname = picom-animations-git
diff --git a/PKGBUILD b/PKGBUILD
index 3872d61790b6..d0c967ef64f6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,19 @@
+# Maintainer: jzbor <jzbor at posteo dot net>
+
+# This PKGBUILD is forked from picom-git
+# Contributors of picom-git:
# Maintainer: WorMzy Tykashi <wormzy.tykashi@gmail.com>
# Contributor: OK100 <ok100 at lavabit dot com>
# Contributor: Valère Monseur <valere dot monseur at ymail dot com>
-pkgname=picom-git
+_forkname=dccsillag
+pkgname=picom-animations-git
_gitname=picom
-pkgver=1430_8.rc2.21.gfd6ff82_2020.06.06
+pkgver=1666_Next.104.g6a50198_2021.09.19
pkgrel=1
-pkgdesc="X compositor (fork of compton) (git-version)"
+pkgdesc="X compositor (fork of compton) (git-version; animation fork)"
arch=(i686 x86_64)
-url="https://github.com/yshui/${_gitname}"
+url="https://github.com/${_forkname}/${_gitname}"
license=('MIT' 'MPL2')
depends=('libgl' 'libev' 'pcre' 'libx11' 'xcb-util-renderutil' 'libxcb' 'xcb-util-image' 'libxext'
'pixman' 'libconfig' 'libdbus' 'hicolor-icon-theme')
@@ -20,8 +25,8 @@ optdepends=('dbus: To control picom via D-Bus'
provides=('compton' 'compton-git' 'picom')
conflicts=('compton' 'compton-git' 'picom')
replaces=('compton-git')
-source=(git+"https://github.com/yshui/${_gitname}.git#branch=next")
-md5sums=("SKIP")
+source=(git+"https://github.com/${_forkname}/${_gitname}.git#branch=implement-window-animations")
+sha256sums=("SKIP")
pkgver() {
cd ${_gitname}