summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJulian Mac Kenzie2021-12-19 17:22:17 +0200
committerJulian Mac Kenzie2021-12-19 17:22:17 +0200
commit5920410c23345ef710e5d34d6e877e70f4dcc403 (patch)
treec980bc39117480828059073715ac2a4d2a4cd873
downloadaur-5920410c23345ef710e5d34d6e877e70f4dcc403.tar.gz
Added PKGBUILD and .SRCINFO
-rw-r--r--.SRCINFO44
-rw-r--r--PKGBUILD36
2 files changed, 80 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c4298e7c7acd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,44 @@
+pkgbase = picom-arian8j2-git
+ pkgdesc = Arian8j2's picom fork with everything from jonaburg's fork plus a patch for rounded corners and shadows
+ pkgver = 0.1
+ pkgrel = 1
+ url = https://github.com/Arian8j2/picom
+ arch = i686
+ arch = x86_64
+ license = MIT
+ license = MPL2
+ makedepends = git
+ makedepends = meson
+ makedepends = ninja
+ makedepends = gcc
+ makedepends = asciidoc
+ makedepends = uthash
+ depends = libconfig
+ depends = libev
+ depends = libxdg-basedir
+ depends = pcre
+ depends = pixman
+ depends = xcb-util-image
+ depends = xcb-util-renderutil
+ depends = hicolor-icon-theme
+ depends = libglvnd
+ depends = libx11
+ depends = libxcb
+ depends = libxext
+ depends = libdbus
+ optdepends = dbus: To control picom via D-Bus
+ optdepends = xorg-xwininfo: For picom-trans
+ optdepends = xorg-xprop: For picom-trans
+ optdepends = python: For picom-convgen.py
+ provides = compton
+ provides = compton-git
+ provides = picom
+ provides = picom-git
+ conflicts = compton
+ conflicts = compton-git
+ conflicts = picom
+ conflicts = picom-git
+ source = picom::git+https://github.com/Arian8j2/picom.git
+ md5sums = SKIP
+
+pkgname = picom-arian8j2-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..61acccc52058
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Julian Mac Kenzie <jukiangm@gmail.com>
+_gitfolder="picom"
+pkgname=picom-arian8j2-git
+pkgver=0.1
+pkgrel=1
+pkgdesc="Arian8j2's picom fork with everything from jonaburg's fork plus a patch for rounded corners and shadows"
+arch=(i686 x86_64)
+url="https://github.com/Arian8j2/picom"
+license=('MIT' 'MPL2')
+depends=('libconfig' 'libev' 'libxdg-basedir' 'pcre' 'pixman' 'xcb-util-image' 'xcb-util-renderutil' 'hicolor-icon-theme' 'libglvnd' 'libx11' 'libxcb' 'libxext' 'libdbus')
+makedepends=('git' 'meson' 'ninja' 'gcc' 'asciidoc' 'uthash')
+optdepends=('dbus: To control picom via D-Bus'
+ 'xorg-xwininfo: For picom-trans'
+ 'xorg-xprop: For picom-trans'
+ 'python: For picom-convgen.py')
+provides=('compton' 'compton-git' 'picom' 'picom-git')
+conflicts=('compton' 'compton-git' 'picom' 'picom-git')
+source=("${_gitfolder}::git+https://github.com/Arian8j2/picom.git")
+md5sums=("SKIP")
+build() {
+ cd "${srcdir}/${_gitfolder}"
+ meson --buildtype=release . build --prefix=/usr -Dwith_docs=true
+ ninja -C build
+}
+
+package() {
+ # this is adapted from tryone144's fork PKGBUILD
+ cd "${srcdir}/${_gitfolder}"
+ DESTDIR="$pkgdir/" ninja -C build install
+
+ # install license
+ install -D -m644 "LICENSES/MIT" "${pkgdir}/usr/share/licenses/${pkgname/-git$/}/LICENSE-MIT"
+
+ # example conf
+ install -D -m644 "picom.sample.conf" "${pkgdir}/etc/xdg/picom.conf.example"
+}