summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoe Groocock2020-04-11 21:18:03 +0100
committerJoe Groocock2020-04-11 21:18:03 +0100
commit5a34fd50160084fea0254acaeef3d884e775d35b (patch)
tree3ba649d4a1a907c9ab07b3728930b91dd02a2509
parentd2a602e17d7031a46901fd51dcda79fd44472c4b (diff)
downloadaur-5a34fd50160084fea0254acaeef3d884e775d35b.tar.gz
Attempt to make rebase slightly more likely to succeed
This is also more likely to produce invalid code, especially if there is a conflict in a .c/.h file, but either way it would fail to build so I guess it's at least worth trying
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD8
2 files changed, 7 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 113929a3ed6c..bf5bc056cc73 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = picom-tryone-git
pkgdesc = tryone144's picom fork with dual_kawase blur, an X compositor (fork of compton)
- pkgver = 1389_Next.108.g8877844_2020.04.09
+ pkgver = 1417_Next.136.g7a3137b_2020.04.11
pkgrel = 1
url = https://github.com/tryone144/picom/tree/feature/dual_kawase
arch = i686
diff --git a/PKGBUILD b/PKGBUILD
index 2266d497902b..f24de31163c3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=picom-tryone-git
_gitname=picom
-pkgver=1389_Next.108.g8877844_2020.04.09
+pkgver=1417_Next.136.g7a3137b_2020.04.11
pkgrel=1
pkgdesc="tryone144's picom fork with dual_kawase blur, an X compositor (fork of compton)"
arch=(i686 x86_64)
@@ -40,7 +40,11 @@ prepare() {
git config --local user.email picom@makepkg.aur
git rebase --abort 2>&1 >/dev/null || :
git fetch https://github.com/yshui/picom.git next
- git rebase FETCH_HEAD
+ git -c commit.gpgsign=false rebase \
+ --fork-point \
+ --rerere-autoupdate \
+ --strategy-option=ours \
+ FETCH_HEAD
}
build() {