summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMikael Tillenius2015-07-06 12:34:34 +0200
committerMikael Tillenius2015-07-06 12:34:34 +0200
commit375c80ef565263af1b07d1ee9842950554570b89 (patch)
treeac6b8bd45b0db75ac19316911af6b4d7be613265
downloadaur-375c80ef565263af1b07d1ee9842950554570b89.tar.gz
Initial import
-rw-r--r--.SRCINFO27
-rw-r--r--95-pico.rules50
-rw-r--r--PKGBUILD47
-rw-r--r--picoscope.install6
4 files changed, 130 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..07740f54cbb7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = picoscope
+ pkgdesc = gui for picotech oscilloscope
+ pkgver = 6.10.1_4r36
+ pkgrel = 1
+ url = http://www.picotech.com/linux.html
+ install = picoscope.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = dpkg
+ depends = mono
+ depends = mono-tools
+ depends = libpicoipp
+ depends = desktop-file-utils
+ optdepends = libps3000: support for picoscope 3000 series
+ optdepends = libps2000: support for picoscope 2000 series
+ optdepends = libps2000a: support for picoscope 2000 series
+ options = !strip
+ source = http://labs.picotech.com/debian/pool/main/p/picoscope/picoscope_6.10.1-4r36_all.deb
+ source = picoscope.install
+ source = 95-pico.rules
+ md5sums = 961072e9080fb0b41cf25dc25caeb6c0
+ md5sums = 503df69f2e6001e3e9269970a552af13
+ md5sums = afedfca88c003ead013c18f26f789fd4
+
+pkgname = picoscope
+
diff --git a/95-pico.rules b/95-pico.rules
new file mode 100644
index 000000000000..a1f0fd8240cb
--- /dev/null
+++ b/95-pico.rules
@@ -0,0 +1,50 @@
+# Rule for Pico Technology USB Oscilloscopes and Dataloggers
+#
+# Copy this file to /etc/udev/rules.d to install it.
+# Udev rules files should normally belong to root:root and
+# have permissions 0644. They are parsed in alphabetical
+# order when a device is connected (with rules parsed later
+# taking priority over those relating to the same device
+# which have been parsed earlier). With the default
+# filename, 95-pico.rules, the device-file ownership and
+# permission rules in this file will have priority over most
+# others that may already be installed. If you are sure that
+# this is not what you want, you can simply rename the file
+# (for example, to 05-pico.rules to give it near-minimum
+# priority).
+#
+# On older systems you may need to use udevcontrol
+# to cause udev to reread the rules files as follows if you want
+# the rule to take immediate effect without restarting udev:
+#
+# udevcontrol reload_rules
+#
+# This isn't needed on newer systems (rules files are reread
+# automatically) but it won't do any harm either.
+#
+# The rule below matches USB devices with Pico Technology's VID: 0CE9.
+# It changes the group of the newly-created device node to "pico" and
+# sets the file permissions to 660 (RW for the owner and group). Note
+# that the two idVendor parts (with SYSFS and ATTRS) are used by older
+# and newer udev systems to retrieve the same information: the one
+# that is not applicable will simply be ignored.
+#
+# To use this you should create a group called "pico" and add any users
+# who need to access the pico devices to it. On a typical system you can
+# achieve this by executing the following commands as root:
+# * To create the group:
+#
+# addgroup pico
+#
+# * To add a user called bob to the group
+#
+# usermod -a -G pico bob
+#
+# (the -a specifies that bob should be added to the pico group
+# in addition to any groups of which he is currently a member)
+#
+# You will probably need to logout and login for the changes to take effect
+
+
+SUBSYSTEMS=="usb", ATTRS{idVendor}=="0ce9", MODE="664",GROUP="pico"
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..df7a02671dfd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# thanks for update: Mikael Tillenius (mti) <mti at tillenius dot com>
+# Maintainer: aAXEe <axel at brasshack dot de>
+# Submitter: Alexandre Bique (abique) <>
+pkgname=picoscope
+pkgver=6.10.1_4r36
+pkgrel=1
+pkgdesc="gui for picotech oscilloscope"
+arch=('i686' 'x86_64')
+url="http://www.picotech.com/linux.html"
+license=('GPL')
+groups=()
+depends=(mono mono-tools libpicoipp desktop-file-utils)
+makedepends=(dpkg)
+optdepends=('libps3000: support for picoscope 3000 series'
+ 'libps2000: support for picoscope 2000 series'
+ 'libps2000a: support for picoscope 2000 series')
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=(!strip)
+install=picoscope.install
+changelog=
+source=(
+ "http://labs.picotech.com/debian/pool/main/p/${pkgname}/${pkgname}_${pkgver//_/-}_all.deb"
+ "picoscope.install"
+ "95-pico.rules")
+md5sums=('961072e9080fb0b41cf25dc25caeb6c0'
+ '503df69f2e6001e3e9269970a552af13'
+ 'afedfca88c003ead013c18f26f789fd4')
+
+noextract=()
+
+build() {
+ echo
+}
+
+package() {
+ mkdir -p $pkgdir/etc/udev/rules.d/
+ install -m644 95-pico.rules $pkgdir/etc/udev/rules.d/
+ dpkg --extract "${pkgname}_${pkgver//_/-}_all.deb" $pkgdir
+ chmod -R go-w $pkgdir
+ chown -R root:root $pkgdir
+
+ mkdir -p $pkgdir/usr/bin
+ ln -s /opt/picoscope/bin/picoscope $pkgdir/usr/bin/picoscope
+}
diff --git a/picoscope.install b/picoscope.install
new file mode 100644
index 000000000000..5f76aae511ff
--- /dev/null
+++ b/picoscope.install
@@ -0,0 +1,6 @@
+#! /bin/bash
+
+post_install() {
+ update-desktop-database -q
+ groupadd --force --system pico
+}