summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoreric2021-12-15 15:45:21 -0500
committereric2021-12-15 15:45:21 -0500
commit2bfbaa0582d67fc8e67fab32bbdcb8ee90e35da7 (patch)
tree55edff04a495ec6fafa47a58e2285e2ce1b1860b
downloadaur-2bfbaa0582d67fc8e67fab32bbdcb8ee90e35da7.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD25
3 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cf419bdef83b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = picosnitch
+ pkgdesc = Protect your privacy, see which processes make remote network connections
+ pkgver = 0.7.1
+ pkgrel = 1
+ url = https://elesiuta.github.io/picosnitch/
+ arch = any
+ license = GPL3
+ makedepends = python-setuptools
+ depends = python-bcc
+ depends = dbus-python
+ depends = python-psutil
+ depends = python-requests
+ source = picosnitch-0.7.1.tar.gz::https://github.com/elesiuta/picosnitch/releases/download/v0.7.1/picosnitch.tar.gz
+ sha256sums = b9677ed2adb4a38375b3c78b7fc36bf99740a0a64f82f3c6728ba604e89e11f5
+
+pkgname = picosnitch
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..72e8ffc0db8a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cfab3448668c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer : Eric Lesiuta <elesiuta@gmail.com>
+
+pkgname=picosnitch
+pkgver=0.7.1
+pkgrel=1
+pkgdesc='Protect your privacy, see which processes make remote network connections'
+arch=('any')
+url='https://elesiuta.github.io/picosnitch/'
+license=('GPL3')
+depends=('python-bcc' 'dbus-python' 'python-psutil' 'python-requests')
+makedepends=('python-setuptools')
+optdepends=()
+provides=()
+conflicts=()
+source=("picosnitch-${pkgver}.tar.gz::https://github.com/elesiuta/picosnitch/releases/download/v${pkgver}/picosnitch.tar.gz")
+sha256sums=('b9677ed2adb4a38375b3c78b7fc36bf99740a0a64f82f3c6728ba604e89e11f5')
+
+build() {
+ python setup.py build
+}
+
+package() {
+ python setup.py install --prefix='/usr' --root="$pkgdir" --skip-build --optimize='1'
+ install -D -m644 "${srcdir}/debian/picosnitch.service" "${pkgdir}/usr/lib/systemd/system/picosnitch.service"
+}