summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoryjun2023-07-30 01:15:47 +0800
committeryjun2023-07-30 01:15:47 +0800
commit8974b33ee6c1e038bbe58d1ccd7da597ed652885 (patch)
tree6d779136a4d0577fa615fc87384a6c632caf9596
parent42436c5f5a08ee0499f66440c22371f2c042c2b0 (diff)
downloadaur-8974b33ee6c1e038bbe58d1ccd7da597ed652885.tar.gz
[updpkg]: picsimlab-bin 0.9.0
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD18
2 files changed, 12 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e24ea9c98469..2725f8e803d7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = picsimlab-bin
pkgdesc = A realtime emulator of development boards with integrated MPLABX/avr-gdb debugger
- pkgver = 0.8.12
+ pkgver = 0.9.0
pkgrel = 1
url = https://github.com/lcgamboa/picsimlab
arch = x86_64
@@ -19,7 +19,7 @@ pkgbase = picsimlab-bin
depends = zlib
provides = PICSimLab
conflicts = PICSimLab
- source = PICSimLab-0.8.12.deb::https://github.com/lcgamboa/picsimlab/releases/download/v0.8.12/PICSimLab_0.8.12_230120_Ubuntu_20.04.5_LTS_amd64.deb
- sha256sums = 1d7e17d63ed4f9a7d3226e298d7c6819a4d702af3677eabe05447e8f499d882d
+ source = PICSimLab-0.9.0.deb::https://sourceforge.net/projects/picsim/files/latestbuild/PICSimLab_0.9.0_230728_Ubuntu_20.04.6_LTS_amd64.deb/download
+ sha256sums = 425af9de1bb7e208d6a719b42d543ffa139d596b04c1db1d62a760ce110f33e4
pkgname = picsimlab-bin
diff --git a/PKGBUILD b/PKGBUILD
index 1f7006704fa6..9e5914cf7623 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,16 +3,16 @@
pkgname=picsimlab-bin
_pkgname=PICSimLab
-#_pkgname=${pkgname%-bin}
-_date=230120
-pkgver=0.8.12
+_pkgname2=${pkgname%-bin}
+_date=230728
+pkgver=0.9.0
pkgrel=1
pkgdesc="A realtime emulator of development boards with integrated MPLABX/avr-gdb debugger"
arch=('x86_64')
url='https://github.com/lcgamboa/picsimlab'
license=('GPL2')
-provides=("${_pkgname}")
-conflicts=("${_pkgname}")
+provides=("${pkgname%-bin}")
+conflicts=("${pkgname%-bin}")
depends=('gtkwave'
'gpsim'
'libgcrypt'
@@ -25,9 +25,9 @@ depends=('gtkwave'
'wxgtk3'
'zlib')
makedepends=('tar')
-source=("${_pkgname}-${pkgver}.deb::${url}/releases/download/v${pkgver}/${_pkgname}_${pkgver}_${_date}_Ubuntu_20.04.5_LTS_amd64.deb")
-# source=("${_pkgname}-${pkgver}.deb::https://sourceforge.net/projects/picsim/files/v${pkgver}/${_pkgname}_${pkgver}_Ubuntu_20.10_amd64.deb/download")
-sha256sums=('1d7e17d63ed4f9a7d3226e298d7c6819a4d702af3677eabe05447e8f499d882d')
+# source=("${_pkgname}-${pkgver}.deb::${url}/releases/download/v${pkgver}/${_pkgname}_${pkgver}_${_date}_Ubuntu_20.04.5_LTS_amd64.deb")
+source=("${_pkgname}-${pkgver}.deb::https://sourceforge.net/projects/picsim/files/latestbuild/${_pkgname}_${pkgver}_${_date}_Ubuntu_20.04.6_LTS_amd64.deb/download")
+sha256sums=('425af9de1bb7e208d6a719b42d543ffa139d596b04c1db1d62a760ce110f33e4')
package() {
# extract
@@ -39,6 +39,6 @@ package() {
# icon
for icon in espmsim picsimlab srtank
do
- install -Dm644 ${pkgdir}/usr/share/${_pkgname}/$icon.png -t ${pkgdir}/usr/share/pixmaps/
+ install -Dm644 ${pkgdir}/usr/share/${_pkgname2}/$icon.png -t ${pkgdir}/usr/share/pixmaps/
done
}