summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorasm0dey2018-06-07 21:11:40 +0300
committerasm0dey2018-06-08 13:22:29 +0300
commit30dff7285ecb9feb8e3a8d114e8bbe6d0ee78917 (patch)
treece63f12f249a1acc23996ed79d48b0ee5af9b840
parent8f8bfb2165a3be3b9fed5c7e14d915a4a883dedb (diff)
downloadaur-30dff7285ecb9feb8e3a8d114e8bbe6d0ee78917.tar.gz
initial
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD54
2 files changed, 26 insertions, 42 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 083ffe26c009..7b298a6f2c42 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,13 @@
pkgbase = pict-git
- pkgdesc = Pairwise Independent Combinatorial Testing
- pkgver = r32.890a384
- pkgrel = 2
+ pkgdesc = Tool for pairwise automation: Pairwise Independent Combinatorial Testing
+ pkgver = 46.e7b0efe
+ pkgrel = 1
url = https://github.com/Microsoft/pict
arch = x86_64
+ arch = i686
license = MIT
- makedepends = git
- makedepends = libstdc++5
- makedepends = clang
- provides = pict
- conflicts = pict
+ makedepends = gcc
+ makedepends = make
source = git+https://github.com/Microsoft/pict.git
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 8954afc8eae2..df1368e9b40e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,47 +1,33 @@
-# This is an example PKGBUILD file. Use this as a start to creating your own,
-# and remove these comments. For more information, see 'man PKGBUILD'.
-# NOTE: Please fill out the license field for your package! If it is unknown,
-# then please put 'unknown'.
-
-# The following guidelines are specific to BZR, GIT, HG and SVN packages.
-# Other VCS sources are not natively supported by makepkg yet.
-
# Maintainer: Florian Schweikert <kelvan@ist-total.org>
+# Maintainer: asm0dey <pavel.finkelshtein@gmail.com>
pkgname=pict-git
-pkgver=r32.890a384
-pkgrel=2
-pkgdesc="Pairwise Independent Combinatorial Testing"
-arch=("x86_64")
-url="https://github.com/Microsoft/pict"
+_pkgname=pict
+pkgver=46.e7b0efe
+pkgrel=1
+pkgdesc='Tool for pairwise automation: Pairwise Independent Combinatorial Testing'
+arch=('x86_64' 'i686')
+url='https://github.com/Microsoft/pict'
license=('MIT')
-groups=()
depends=()
-makedepends=('git' 'libstdc++5' 'clang')
-provides=("${pkgname%-git}")
-conflicts=("${pkgname%-git}")
-replaces=()
-backup=()
-options=()
-install=
-source=('git+https://github.com/Microsoft/pict.git')
-noextract=()
+makedepends=('gcc' 'make')
+source=("git+https://github.com/Microsoft/$_pkgname.git")
md5sums=('SKIP')
-# Please refer to the 'USING VCS SOURCES' section of the PKGBUILD man page for
-# a description of each element in the source array.
-
pkgver() {
- cd "$srcdir/${pkgname%-git}"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ cd "$srcdir/$_pkgname"
+ ( set -o pipefail
+ git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
}
build() {
- cd "$srcdir/${pkgname%-git}"
- make
+ cd "$srcdir/$_pkgname"
+ make
}
-package() {
- cd "$srcdir/${pkgname%-git}"
- install -d "${pkgdir}/usr/bin"
- install "${srcdir}/${pkgname%-git}"/pict "${pkgdir}/usr/bin/"
+package(){
+ cd "$srcdir/$_pkgname"
+ mkdir -p "$pkgdir/usr/bin/"
+ install -m755 "$_pkgname" "$pkgdir/usr/bin/$_pkgname"
}