summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlorian Schweikert2017-03-15 15:23:05 +0100
committerFlorian Schweikert2017-03-15 15:23:05 +0100
commit66d08083c7fc64a06c519e2d04e72a994c680e98 (patch)
tree9172c52fbaa22ea08391b739a36341217780e8ca
downloadaur-66d08083c7fc64a06c519e2d04e72a994c680e98.tar.gz
init
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD47
2 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5ff54fd168c0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = pict-git
+ pkgver = r32.890a384
+ pkgrel = 1
+ url = https://github.com/Microsoft/pict
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ makedepends = libstdc++5
+ makedepends = clang
+ provides = pict
+ conflicts = pict
+ source = git+https://github.com/Microsoft/pict.git
+ md5sums = SKIP
+
+pkgname = pict-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1d6ef4d754d4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# The following guidelines are specific to BZR, GIT, HG and SVN packages.
+# Other VCS sources are not natively supported by makepkg yet.
+
+# Maintainer: Florian Schweikert <kelvan@ist-total.org>
+pkgname=pict-git
+pkgver=r32.890a384
+pkgrel=1
+pkgdesc=""
+arch=("x86_64")
+url="https://github.com/Microsoft/pict"
+license=('MIT')
+groups=()
+depends=()
+makedepends=('git' 'libstdc++5' 'clang')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+replaces=()
+backup=()
+options=()
+install=
+source=('git+https://github.com/Microsoft/pict.git')
+noextract=()
+md5sums=('SKIP')
+
+# Please refer to the 'USING VCS SOURCES' section of the PKGBUILD man page for
+# a description of each element in the source array.
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$srcdir/${pkgname%-git}"
+ make
+}
+
+package() {
+ cd "$srcdir/${pkgname%-git}"
+ install -d "${pkgdir}/usr/bin"
+ install "${srcdir}/${pkgname%-git}"/pict "${pkgdir}/usr/bin/"
+}