summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJaroslav Lichtblau2014-11-28 20:17:14 +0100
committerJaroslav Lichtblau2014-11-28 20:17:14 +0100
commit633dd743abd1b047130d0496dc661e3b6dac1e8a (patch)
tree584ea8367df5372fb386190cbb94f50093e0d97c
downloadaur-633dd743abd1b047130d0496dc661e3b6dac1e8a.tar.gz
Initial PKGBUILD status as of 28.11.2014
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD25
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7561bd842bca
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = picturesort
+ pkgdesc = Sorts pictures on how they look, not by their metadata
+ pkgver = 0.2
+ pkgrel = 1
+ url = http://www.vanheusden.com/picturesort/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = fftw
+ depends = gcc-libs
+ depends = imagemagick
+ source = http://www.vanheusden.com/picturesort//picturesort-0.2.tgz
+ md5sums = f92580b48bf858207b17603124db449e
+
+pkgname = picturesort
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..53e676b7a487
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Contributor: Christoph Zeiler <rabyte*gmail>
+
+pkgname=picturesort
+pkgver=0.2
+pkgrel=1
+pkgdesc="Sorts pictures on how they look, not by their metadata"
+arch=('i686' 'x86_64')
+url="http://www.vanheusden.com/$pkgname/"
+license=('GPL')
+depends=('fftw' 'gcc-libs' 'imagemagick')
+source=($url/$pkgname-$pkgver.tgz)
+md5sums=('f92580b48bf858207b17603124db449e')
+
+build() {
+ cd $pkgname-$pkgver
+
+ sed -e 's|-O2||g' \
+ -e 's|Graphics||g' \
+ -i Makefile
+
+ make || return 1
+ install -Dm755 $pkgname $pkgdir/usr/bin/$pkgname
+}
+
+# vim:set ts=2 sw=2 et: