summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortmikey2020-09-01 12:32:09 +0100
committertmikey2020-09-01 12:32:09 +0100
commitb6eca5ab18f430e64badb121b89b7953863c88b7 (patch)
tree8d3054ec4bf9b7caf70788664aebfaec45669186
downloadaur-b6eca5ab18f430e64badb121b89b7953863c88b7.tar.gz
initial commit
hello AUR!
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD23
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ed06074a8463
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = pid-fan-controller
+ pkgdesc = PID fan controller with Python3
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://github.com/ThunderMikey/pid_fan_controller
+ arch = any
+ license = GPL3
+ depends = python3
+ depends = python-simple-pid
+ depends = python-pyaml
+ provides = pid-fan-controller
+ source = https://github.com/ThunderMikey/pid_fan_controller/archive/1.0.tar.gz
+ md5sums = 0bf5a7421cb6587e2bb21cd58e0e3b26
+
+pkgname = pid-fan-controller
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1c56527cc0c0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: tmikey
+
+_srcname=pid_fan_controller
+pkgname=pid-fan-controller
+pkgver=1.0
+pkgrel=1
+pkgdesc="PID fan controller with Python3"
+arch=('any')
+url="https://github.com/ThunderMikey/pid_fan_controller"
+license=('GPL3')
+depends=('python3' 'python-simple-pid' 'python-pyaml')
+provides=("$pkgname")
+source=(https://github.com/ThunderMikey/pid_fan_controller/archive/$pkgver.tar.gz)
+md5sums=('0bf5a7421cb6587e2bb21cd58e0e3b26')
+
+package() {
+ cd "$_srcname-$pkgver"
+ install -m 644 -Dt "$pkgdir/usr/lib/systemd/system/" pid-fan-controller.service \
+ pid-fan-controller-sleep-hook.service
+ install -m 755 -Dt "$pkgdir/usr/share/$pkgname/" pid_fan_controller.py override_auto_fan_control.py
+}
+
+# vim:set ts=2 sw=2 et: